1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8600 HD broken!

Discussion in 'Blizzard Plows Discussion' started by 2low4nh, Dec 20, 2012.

  1. 2low4nh

    2low4nh Member
    from NH
    Messages: 61

    Okay so I mounted my plow to move it the other dayon't think it was sitting in the mount right and it bent the A-frame. the tabs that lock in on the under carraige are bent up about 1/4" making the holes way off. I can not get a pin in on this at all. It looks like blizzard didnt do a very good job on the welds. anyone know how much a new A-frame is going to cost and where I can buy one. The plow is only like 2 years old and had very little use. I might be able to straighten this out but its going to take some big hammers to move it back the 1/4" :realmad:
     
  2. 2low4nh

    2low4nh Member
    from NH
    Messages: 61

    okay got it fixed today with a big hammer and some heat. laid down some good welds. After looking at the welds I found the problem. most of the welds had very little penetration and just broke. the two plates as well as a support between them all had broken welds. talked with a local guy he said he has seen a few of them do it well mounting them on the truck. oh well guess check your welds and hope it doesn't happen.
     
  3. maelawncare

    maelawncare Senior Member
    Messages: 871

    Yes, this is a known problem with DD products. At least on the blizzard side.

    Inspect all your plows thoroughly before and after each storm. Anything that even looks off, inspect harder.