1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

86 K-30 problems HELP!

Discussion in 'Chevy Trucks' started by tjcezar, Dec 10, 2003.

  1. tjcezar

    tjcezar Member
    Messages: 63

    1986 Chevy K-30 dump 350 4X4 8' Meyer central hyd Monarch pump.
    First of all fellas what does the K-30 stand for? (just woderin)
    Also I am getting voltage spikes where the voltage meter goes all the way up, my heater blows 10X normal, my lights get brighter, and my windshield wipers go so fast they feel like their gonna break. This will happen while I'm driving and will happen intermitently (on and off). I swear Ive gone over every single wire on this truck and still havent fixed it I did find find some bare wires but fixed them and it is still doing it. I took the alt off and had it tested and it is fine. Any HELP PLEASE! :confused:
     
  2. jmassi

    jmassi Senior Member
    Messages: 154

    The K-30 means that it is 4 wheel drive and it is a 1 ton (K=4x4 ; 30=1 ton). As far as the voltage spikes, check your ground cable for your battery and make sure it's making good contact and it isn't rusty or corroded. Also, you may want to have your battery tested to see if it has a shorted cell inside which might cause the spike.

    Good luck!!
     
  3. tjcezar

    tjcezar Member
    Messages: 63

    I checked the ground and cleaned all the connections even changed battery and nothing. Maybe I'll try again. Thanks for the help.
     
  4. towman

    towman Member
    Messages: 39

    sounds like you need to have your alternator checked out, it has an internal regulator that will run your voltage to high if bad
     
  5. tjcezar

    tjcezar Member
    Messages: 63

    Well I took the alternator off and had it tested at 2 different places. Both told me it was fine. after tha t I just gave up and took it to my local mechanic. Guess what? It was the damn alternator anyway and now I had to pay to have someone else put it on. Yeah well LIVE n LEARN Don't ever trust the bozos behind the counter t PEP BOYS or AUTO ZONE :gunsfiring:
     
  6. towman

    towman Member
    Messages: 39

    if you ever run into that again you should also check the voltage at the red wire that plugs into the alternator in the white plastic plug, if the voltage reads lower there than at the battery it will make the regulator over charge also,
     
  7. tjcezar

    tjcezar Member
    Messages: 63

    well guess what? Its doing it again. I guess it wasn t the alt to begin with. Now when it over charges though it wont run and sputters. I give it gas and it just spuitters barely moving.
     
  8. chevy

    chevy Member
    Messages: 33

    Electrical problems don't you just love'm. Hows the body to engine ground? Check that out it will also give you a pile of head aches. The engine sputtering sounds like you might have fried a coil or a module. This is very possible with over charging. How much over charging is it. It still can be the alternator, they do make defective ones. Especially if its from Pep Boys,Auto Zone or any other quality auto part store like that:rolleyes: Hook up a charge meter to the back of the alternator and run it and see if you can get the alt. to spike if it does; then unhook the wire off of the back of the alt. and try to get it to spike again. If it doesn't spike then most likely you have a short some where. If it does spike then throw the alt. threw Pep Boys window. There test equipment for alt. won't show if the alt. faulty when it gets hot like on an engine running. I had the same problem with Advance Auto. I go to bumper and bumper or Acme a good parts store the price might be a little more but you do the job once. Good luck :)
     
  9. tjcezar

    tjcezar Member
    Messages: 63

    thanks for the great info. I'll keep ya POSTED after i go through everything.
     
  10. towman

    towman Member
    Messages: 39

    you really do need to check your voltage at the plastic plug like i said, if is lower than the thread on post at the back of the alt it will make it overcharge, just went thru the same thing on a 84 chev