1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8'6" EZV losing functions

Discussion in 'Truck & Equipment Repair' started by WHTTLHNTR, Dec 16, 2013.

  1. WHTTLHNTR

    WHTTLHNTR Junior Member
    from Raymond
    Messages: 20

    Yestarday was the day from hell for me. I am sure we have all had bad days. My plow will not angle like a straight blade. I can move each side individually and scoop and vee work as they should and moving when in the mode to move each side that works. When I am just the regular mode (not sure that is the right terminology) if I angle to the left the left side will move but right will not and vice versa. When if first happened I got out and just grabbed the blade and gave it a good shake and it worked for a little while then went back to doing what it was doing before. I checked the fluid level, made sure all connections were connnected (i have not checked with a test light yet). It worked enough to finish the day night but what a PITA. All I can think of is the pump is not functioning properly. Thanks for any suggestions.
     
  2. WHTTLHNTR

    WHTTLHNTR Junior Member
    from Raymond
    Messages: 20

    I noticed today that my breather hissing quite a bit. I have not noticed this with my other plows. Noticeable enough I can hear it over my engine noise (6.0 diesel). Anyways, is this something that could be causing the above problem? This is the last thing I need is a big expense with my plow. I lost four wheel drive first this yesterday morning during the storm, then lost reverse once it broke light, last lot of the storm I blew a hose. I guess it keeps it interesting.