1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

85 dodge ram 4x4 318

Discussion in 'Ram Trucks' started by tphawk09, Feb 3, 2008.

  1. tphawk09

    tphawk09 Member
    Messages: 41

    plowing yesterday for 1 hr and truck died all i smelt was gas then after 2 hrs or sitting it started up no probs then about an hr did the same thing it ran great up untill yesterday thanks
     
  2. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 8,574

  3. Wiseguyinc

    Wiseguyinc Member
    from MN
    Messages: 56

    I had a similar thing happen with mine a few years ago. It was my automatic choke freaking out and staying on. It would stall every time the engine got warmed up. then it would not restart until it cooled down.
     
  4. DeereFarmer

    DeereFarmer PlowSite Veteran
    Messages: 3,296

    I agree with wiseguy. You might want to check the fuel sending unit ontop of the gas tank and see if it is leaking as well. I've had that problem before too.
     
  5. streetsurfin'

    streetsurfin' Senior Member
    Messages: 770

    What carberator do you have?

    What carberator do you have? Check vacuum line for leak or good vacuum to the choke pull off diaphragm. Is there an electric choke? If so, it's timer may be bad. I think that is only on the Quadrajet though. I think also there was an issue with a passage in the manifold that gets clogged with carbon and does not allow proper timely heating of the choke coil in the manifold in order to pull off the choke. Are your temp and oil pressure guages reading correctly? The choke pull off is also controlled by coolant temp sensor in some cases, I think.
     
  6. tphawk09

    tphawk09 Member
    Messages: 41

    its a 1 yr old holly 2 barrel i heard that ethonal blend is bad would that cause it to just die i was also told mabe the ignition modual thanks for helping me out i ran it today ran for 2 hrs with no prob im stunped
     
  7. Wiseguyinc

    Wiseguyinc Member
    from MN
    Messages: 56

    When your engine is up to temp take off your air filer with engine running and check to see if the butterfly valve is still closed for the choke. If so you have narrowed it down. If not maybe you have a rusty connection on your ignition somewhere.
     
  8. tphawk09

    tphawk09 Member
    Messages: 41

    hi the butterfly is not closed im stunned what do u mean ignition conection rusty where would i look thanks
     
  9. Wiseguyinc

    Wiseguyinc Member
    from MN
    Messages: 56

    In mine it acted up when the screws that hold the ballast resistor on the fender got rusty. I cleaned them up and put oil on them. Just check any little connection like that and make sure it's not rusty or crusty.
     
  10. baltz526

    baltz526 Member
    Messages: 32

    float is stuck open