1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

83 Chevy K10 wiring issue

Discussion in 'Chevy Trucks' started by Davidl79, Dec 26, 2010.

  1. Davidl79

    Davidl79 Junior Member
    Messages: 15

    I have an 83 Chevy K10. I was driving a couple days ago and lost my dash lights, marker lights and tail lights. when you pull the knob for the lights the dome light and a light under the dash come on. We tested the headlight switch and it was bad. I replaced it today and nothing changed. I checked the fuse panel and I'm not getting any power to that fuse. Someone also took out the 5amp fuse and replaced it with a 25amp. It must have been like this for years because I never had to replace it.

    I looked on autozone for the wiring diagram and it kinda sucks. I was wondering if someone had a website to get a good diagram from. I think I'm going to have to do a lot of troubleshooting before the next storm.
    Thanks,
    Dave
     
  2. sweetk30

    sweetk30 PlowSite.com Addict
    Messages: 1,588

    tons of good info on these trucks at www.ck5.com

    and lots on upgrade for the crapy worn out system on headlights. you will like it. simple search should find it. sorry i dont have the page saved to link ya to.
     
  3. Davidl79

    Davidl79 Junior Member
    Messages: 15

    Thanks for the help!! That site looks awesome. I'm sure it will help a lot.
     
  4. magik235

    magik235 Senior Member
    Messages: 113

    [​IMG]
     
  5. welded wrenches

    welded wrenches Senior Member
    Messages: 177

    tail / dash light issues

    hi,tail lighs and dash lights are the same fuse..checkthe black ground wire at rear tail lights.(behind and below tail lights.)prone to breaking off the black ground wire,also check the the ground wire from bed to frame.and groundwire fro cab to frame.or may have burned-melted tail light harness wires on passenger side frame rail..caused by hot exhaust pipe.= dead short.ok..
     
  6. sweetk30

    sweetk30 PlowSite.com Addict
    Messages: 1,588

    the wiring runs down the left frame rail not the right. and is tucked up in the box cross bar for the left to right lights.

    and yep the tab were the ground bolts to the box behind the left tail light housing rots off.
     
    Last edited: Jan 1, 2011
  7. Davidl79

    Davidl79 Junior Member
    Messages: 15

    I'm going to pull it into the shop tonight and trace down all the wires. I have checked all the wires under the dash. Hopefully it is just a broken ground. Thanks for all the help!!!!!!!!