1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

810 problems!

Discussion in 'Blizzard Plows Discussion' started by Mike S, Nov 19, 2009.

  1. Mike S

    Mike S PlowSite.com Addict
    Messages: 1,588

    Went to hook the plow up today and it worked fine. Did all of the pre season check and maint and that went fine. Got done touching up some rust spots and went to hook it back up, drove up to it, pluged it in, turned on the control box and it hooked on and raised the plow. Drove the plow to its parking place to drop it and the motor would run but it would not go down. I messed with all of the conections and now the light on the control is flashing. Ive checked and cleaned the conections ten times. Is it the harness?:help::cry:
     
  2. beam

    beam Senior Member
    from pa
    Messages: 314

    does it go to float? if not check and make sure the pins on the plow side are all there and see if it is stuck in the truck side and if it is get a nail to jump it to un mount and you will need a new harness 180 bucks:cry:
     
  3. Mike S

    Mike S PlowSite.com Addict
    Messages: 1,588

    Ok just checked all pins are there and no float. Any other thoughts?
     
  4. sonjaab

    sonjaab PlowSite.com Addict
    Messages: 1,425

    Mike.........Its too bad that certain JERK that posts here (ron) pissed off Jerre and ran him off
    with his constant harassing, whining, etc. otherwise the "Blizzard wizard" would of had a
    answer for you in a flash!

    Hopefully some other JERK won't piss off Crash and the other fisher/western gurus that
    help out elsewhere around here.
     
  5. 3311

    3311 Senior Member
    Messages: 332

    He is still here but doesn't want anyone to know. You could just call him on the phone couldn't you ? What is the area code for Emerald City anyway ?
     
  6. lilweeds

    lilweeds PlowSite.com Addict
    Messages: 1,178

  7. sonjaab

    sonjaab PlowSite.com Addict
    Messages: 1,425

    3311............Thats a good one!...........................lol!:dizzy:
     
  8. 4evergreenlawns

    4evergreenlawns Senior Member
    Messages: 552

    Rsvees,

    Could not have posted it better myself.

    Ron G.
     
  9. 4evergreenlawns

    4evergreenlawns Senior Member
    Messages: 552

    Thanks for the update as to why the questions asked went left unanswered. I am glad ot see Jerre found a new found voice. I was wondering if was was getting my point across.

    So lets think about this, YOU could have:

    A) as posted by Rsvees, the "Blizzard Wizzard" has a web site you would have served this member mush better by directing him to that direct contact information, did you do that NO!!!!!!

    B) you could have directed him to LETS TALK (all about how great Jerre is) SNOW web site. did you do that NO!!!!!!!!

    C) you could have given him some advice based on your personal expereience with Blizzard plows, NOPE!!!!!

    D) you could have sent him a PM and told him your personal referal to where to find Jerre Heyer, NADAAAAA!!!!!

    You chose none of the above and instead you probably only gave him a reason to look up what a "JERK" like me how actaully owns and has expereince with mulitable versions of the Bliizzard product line has to say about the "Blizzard Wizzard".

    Thank you from the honorable mention. I only hope I can return the favor.

    Oh, BTW, Hope you used a federal grant for that business and marketing education. If not you really pissed some $$$$$ into the wind.

    Ron G
    A.K.A. Pillar of Truth OR "JERK"
     
    Last edited: Nov 20, 2009
  10. 4evergreenlawns

    4evergreenlawns Senior Member
    Messages: 552

    Mike S,

    I would have to guess is it a 810 but you might have something else besides the one listed.

    If the motor is running but not going down do you have any other functions?

    Does the plow operate VIA the power hitch??

    Check the plug all the solinoid positive side go to. You could be getting a cross over there.

    I would check the diode easy part to switch not too expensive to keep in the truck on hand and seems like it is always the cause of crazy operation.

    If it is not that how old is your joy stick? I have had it go bad and get cross functioning.

    The motor should NOT be running when going DOWN. This should give you some things to look at if you say all the PINS are good on the plow side and nothing is stick in on the truck side.

    Keep us up to date. Of course getting in touch with Jerre is advisable but he is NOT the only person with knowledge about this product 2000/2001ish is long gone. I do not think DD appointed him the "Blizzard Wizzard" and I am sure "Wizzard" might have something to say about the partial use of his sign on, not too sure, but you can asked should you talk to him directly. I know him as the oricale of all things known about everything properly authorized to do nothing.

    Ron G.
     
    Last edited: Nov 20, 2009
  11. Mike S

    Mike S PlowSite.com Addict
    Messages: 1,588

    Ok this what i just tried, I have a UPC control and Jerre thought that might be the problem so I just took it out and put the old control in.

    The power hitch switch will make the motor run but it will not go up or down. When you go back in the cab and switch th control out of power hitch mode it I have nothing but the light flashes.

    I checked and cleaned every conection and re greased all contacts.

    What is the Diode? Where is that at?
     
    Last edited: Nov 20, 2009
  12. 4evergreenlawns

    4evergreenlawns Senior Member
    Messages: 552

    You can do a pin test between the contoller side of the plug in the cab and the plug at the bumper. Use the wire diagram that came with the plow. You can isolate this problem. Follow the harness from plug to plug it could have rubbed or touched something hot to overheat the jacket. Also they make a repair harness if you are good with splicing and heat shrinking. Just had a repair harness put on the F-450 that was in the front end crash.

    Never forget what momma told you about a free lunch and what dad told you about free advice. Beware of the "take a trip to Erie advice". :laughing:

    Many here should understand my company has more hours of cutting on the ground than many repair shop have seen plow damage. Just because I do not report each and every thing I deal with does not mean the only knowledge I have is what comes and goes out of Erie. PA.

    Ron G.
     
    Last edited: Nov 20, 2009
  13. Mike S

    Mike S PlowSite.com Addict
    Messages: 1,588

    I changed my last post!!!! LOL!
     
  14. 4evergreenlawns

    4evergreenlawns Senior Member
    Messages: 552

    Ok so when you say light flashing are you talking about the shoebox float light or something on the UPC controller? I know NOTHING about the UPC controller to date. Will have 2 in a few days. Guess not where from??

    The diode, run down the wire harness under the plow cover. You will find a leg of a few wires, can not remember 4 or 6 that go to a plug that has a shrink wraped end going to nothing. You unplug the funny looking shrink wrap looking think (diode) and replace it with a new one. Easy and quick rules out crazy operation like stick left plow goes right. UNLESS you had your plow installed at RA ADAMS.(3311)

    Ron G.
     
    Last edited: Nov 20, 2009
  15. 4evergreenlawns

    4evergreenlawns Senior Member
    Messages: 552

    Mike,

    How about some quid pro quo, however off topic. I could offer a glass of wine and some beans if that would make you feel better....:laughing:

    I own a 07 Toro Dingo 525 Wide track have been thinking about a snow application for this unit. Can you tell me where do you keep it during the winter season for snow work? On sire in a container it trailer it to the job. I am concerned about how the cold will impact the hydros and starting.

    Also you have the plow what other snow attachment have you used or would you recommend. We do a sub division would over 50K Sq.Ft. just in plubic walks alone not to include at entry walks or stoops.


    TIA, RON G.
     
  16. Mike S

    Mike S PlowSite.com Addict
    Messages: 1,588

    the upc has a back lit key pad, it flashes, and the float light on the shoe box flashes also.
     
  17. 4evergreenlawns

    4evergreenlawns Senior Member
    Messages: 552

    10-4.

    Hand a 860SW on the 2500 you would like it and even more if you have to put a driver in in it.

    Ron G
     
  18. Mike S

    Mike S PlowSite.com Addict
    Messages: 1,588

    The dingo is awsome!!!!!! I built the blade for it and im very impressed! I think you could run a six foot blade just fine. Mine is a gas unit and it runs and starts fine but the hydro needs to warm up. Some times if I dont cover the controls they will get a little frozen. If kept outside like I do cover the controls.
     
  19. 4evergreenlawns

    4evergreenlawns Senior Member
    Messages: 552

  20. 4evergreenlawns

    4evergreenlawns Senior Member
    Messages: 552

    Did you get it fixed??

    So I hooked up the plow on my service truck and first thing I notice was headligths not switching from Truck to plow when I flip the toggle.

    So I mount the plow and the power hitch works fine. Thats good, I flip the toggle from plower hitch to Plow and down goes the plow and the controller is making a hissing sound. Oh, crap thats not good.

    Move the truck side plug and it works, it not works, it works, it not works. Trouble shoot the relays and find a missing gound. I peal back the wire loom at the truck side plug and the small black wire comes rightout of the plug. Ground that wire and all is good.

    Ok so 1) do I get a truck side repair harness and start the cut, splice, heat shrink dance OR, 2) just run down the one black wire and hook it to ground. I went with 2 and all is fine.

    All things can be fixed.

    Ron G.