1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

810 pp issues help

Discussion in 'Blizzard Plows Discussion' started by THE05HD, Dec 13, 2011.

  1. THE05HD

    THE05HD Member
    from WI
    Messages: 74

    i just put a used (ph1) 810pp on a 99 dodge 3500, first problem i have is the power hitch wont hitch? You can here the pump/motor run but it dead heads ( wont attach or detach ) any help would be greatly appreciated please...............
    Also when i flip the lights to truck, the high beam indicator is on all the time & when you flip the hi/low switch the driver side light goes dim?

    Thanks aaron
     
  2. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    Use a test light at the back of the power hitch switch. Since your pump runs, you know you are getting power trhough the brown wire a the switch. Check the white and orange wires while operating the switch. If no power there, bad switch or bad connection on the pink jumper from one side of the switch to the other. Can you raise/lower the plow from the truck side?

    On your lights, guessing wrong adapters. There is some old info on these at another forum. Been awhile since I've done a Dodge install of that vintage.
     
  3. beam

    beam Senior Member
    from pa
    Messages: 314

    need to install another set of relays one to each side for the lights do you hav two on each side already? check your ground and clean your plug
     
  4. hlntoiz

    hlntoiz Senior Member
    from NW, CT
    Messages: 588

    There are different adapters for that year. I just did my 1999 and there is a certain wiring combo you need to tell the dealer. Best bet is to call Jerre 1-814-881-4093. He can get you what you need pretty quick and prob help you with your other issue.
     
  5. THE05HD

    THE05HD Member
    from WI
    Messages: 74

    Thanks guys, got the power plow hitch fixed ( needed a new switch) but I still have the light problem? I looked on the blizzard site at the light adapter chart & found nothing on 2 differant adapter kits available for this year truck? As far as the adapter kit I used, it had 1 extra plug after I hooked up the three wire plug to the lights? Does this help anyone? I just find it really strange that the high beam indicator stays on all the time with the plow lights are turned on? Please Please any help would be so great right now!!!!!!
    Thanks Aaron
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,966

    1 extra plug?? how many did your kit come with 4 or 5 ?
     
  7. beam

    beam Senior Member
    from pa
    Messages: 314

    need to install additional relay kit