1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

810 power latch problems

Discussion in 'Blizzard Plows Discussion' started by premo600, Dec 23, 2010.

  1. premo600

    premo600 Junior Member
    Messages: 2

    I bought a 810 power plow after hooking up wire harness into 2000 f 350.. The plow functions all work. But the power latch will not work will not go up or down. i can hear the motor making some noise but nothing any way to bypass the switch so it can be mounted..
  2. premo600

    premo600 Junior Member
    Messages: 2

    Sorry power hitch
  3. damian

    damian Senior Member
    Messages: 330

    use the joystick,check the diode pack.
  4. fastjohnny

    fastjohnny Senior Member
    Messages: 653

    May be your power hitch switch, pull the plug off the back of the switch carefully, it may be corroded. Confirm power at the pink/black wire, then jump that to the brown and white wires for lift, and the brown and orange/red for lower. If you have power at the pink/black wire and this doesn't work, then diode likely bad, as mentioned. If you want to go further, unplug the diode, jump power from the pink/black wire to the orange/white for lift and orange/black for lower, again, must jump the brown wire to trigger the solenoid for pump engagement with both of these as well.