1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

800HD will not hook to truck

Discussion in 'Blizzard Plows Discussion' started by JRT, Jan 17, 2011.

  1. JRT

    JRT Junior Member
    Messages: 24

    Hey guys. New to the site. got a 800HD on a 2002 sierra 2500HD. went to hook up and the lower cylinder not moving with toggle switch on the plow. if i use cab controls it will work? pump is runnin when i use the togle but no movement. fluid level is perfect. noticed a small minor leak at the pump to manifold area when using toggle to engage plow from truck. can i just tighten bolts to fix leak and what to do for toggle? thanks for the help!
     
  2. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    See posts on topic 810 won't unhitch...follow diagnostics...white wire at switch should have power to raise draw latch...

    If you can pin it to your truck, you can use the truck side control to raise draw latch and go plow.
     
  3. JRT

    JRT Junior Member
    Messages: 24

    ok i just cleaned my main connect harness plug and put dielectric grease no help! gonna try checking the toggle switch leads.. the second part relating to the leak, can i just snug the bolts mounting the manifold to pump? or am i looking at a new gasket kit? bought the truck last year with the plow and have had no problems till last night??? thanks jay
     
  4. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    You can try but you may need new orings
     
  5. JRT

    JRT Junior Member
    Messages: 24

    fastjohnny, do u think that leak could be the problem as to why my power hitch wont engage?
    i really don't wanna go to the dealer for this
     
  6. fastjohnny

    fastjohnny Senior Member
    Messages: 654

    Yes. And no. The leak may prevent enoughpressure to lift the plow. But, as you said, the cab controller works. So check plowside switch and harness and fix the leak. Its just two orings.
     
  7. JRT

    JRT Junior Member
    Messages: 24

    thanks for all the advice. i cleaned the whole area under the black plastic cover and then cleaned the main connections with electrical cleaner then put some dielectric grease on all conections. then my upper bolt fot the manifold to pump was loose. snugged that down and everything works perfect no more leaks. just goes to show what a little maintenance can save big bucks!