1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8' Ultramount agngling issue

Discussion in 'Western Plows Discussion' started by bigwhitesierra, Jan 1, 2009.

  1. bigwhitesierra

    bigwhitesierra Junior Member
    Messages: 20

    Have an 8' UltraMount on my Sierra. Every so often when when I try to angle the plow left, it will kick right quick before it goes left. Does not happen all the time. Happened maybe 5-6 times yesterday in 6 hrs of working. Any ideas?
     
  2. GSShelper

    GSShelper Member
    Messages: 98

    had the same problem

    the shop where i got my plow was shooting in the dark with s3 valve (no fix) Poppet valve(no fix),,,, i told them to try putting a new csb command controller on and that was the graphites pad on the circuit board were worn,,, 200 buck for the new guts and everything works fine,, so maybe ask shop to try new controller b4 u start changing semi expensive valves.... G/L

    GssHelper
     
  3. bigwhitesierra

    bigwhitesierra Junior Member
    Messages: 20

    GSS....thanks. I'll check into it...
     
  4. slappysdump

    slappysdump Junior Member
    Messages: 23

    I had a similar problem with my Ultramount, then it stopped going up--that sucked, anyhow the shop messed with it for about an hour and sure enough controller not sending out power--new controller ($300) and the plow works like new now--except for the hydro fitting I need to replace in the a.m. lol.