1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8' MM moving slow

Discussion in 'Fisher Engineering Discussion' started by farmallkid48, Jan 18, 2010.

  1. farmallkid48

    farmallkid48 Junior Member
    Messages: 19

    Just got a truck, came with a MM1 8' plow, PO just put a new motor on it, the plow moves pretty slow, probably a bit slower than my old V-belt setup, are there any valves or something that you can adjust that will make the plow respond a little faster? never used a fisher electric setup, so maybe it's just me?

    Thanks for any help

  2. FordFisherman

    FordFisherman PlowSite.com Addict
    from 06611
    Messages: 1,593

    Start with the basics- Fresh fluid? Good clean electrical connections? Batteries and charging system fuctioning properly?
  3. farmallkid48

    farmallkid48 Junior Member
    Messages: 19

    looks like fresh fluid, might change it this week/weekend don't use this for plowing alot anyways, the connections are good, batteries are good/charging system, like I say it could just be me, I'v never used a Fisher electris setup, just a Monarch pump I setup, and my V-belt...


  4. buddymanzpop

    buddymanzpop Senior Member
    Messages: 597

    There's a filter in the fluid reservoir, take it out and clean it, you'll be amazed at the difference in plow operation.
  5. farmallkid48

    farmallkid48 Junior Member
    Messages: 19

    Thanks, I'll give that a try

  6. bryanlaprad

    bryanlaprad Junior Member
    Messages: 15

    i know this is an old thread and i may sound dumb...but how do you get to the filter in the reservoir???
  7. ChrisFromBoston

    ChrisFromBoston Junior Member
    Messages: 11

    SEHP remove the motor, Insta-Act remove the reservoir.