1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8 ft pro help asap

Discussion in 'Western Plows Discussion' started by ajordan193, Jan 13, 2009.

  1. ajordan193

    ajordan193 Senior Member
    from WNY
    Messages: 224

    8 ft ultra mount pro plow worked all day and then started to move very slowly. The motor spins and the blade moves very slowly. Up and down the plow seems fine but going left and right is where the problem exists. The blade doesn't seem to hold an angle position since i can push and pull the turning rams. Fluid is also full. suggestions???
     
  2. Camden

    Camden PlowSite Fanatic
    Messages: 6,598

    Check your filter, it might be plugged. Also, if you used the truck all day is your battery weak?
     
  3. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Either the Pilot operated check valve has a broken spring or bad o-rings on the cross over relief.
     
  4. ajordan193

    ajordan193 Senior Member
    from WNY
    Messages: 224

    I replaced the battery a month ago, so i doubt that is the problem. Whats the best way to check the filter?
     
  5. ajordan193

    ajordan193 Senior Member
    from WNY
    Messages: 224

    Can you please explain this more...
     
  6. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    Go to the mechanics guide.
     
  7. cfdeng7

    cfdeng7 Senior Member
    from CT
    Messages: 376

    The crossover relief valve releases pressure from the angling pistons when it hits a certain pressure in order to safeguard the hydros. if this valve is bad it could be leaking fluid and therefore resulting in slow and weak angling.
     
  8. ajordan193

    ajordan193 Senior Member
    from WNY
    Messages: 224

    Well now my battery light comes on my dash when trying to move the plow. I had it working better eariler and now its dead again. I changed the middle angling valve which i found was stuck. Where do i go from here?
     
  9. Jon Schuler

    Jon Schuler Member
    Messages: 30

    Alternater taking a puke on you? Might want to check it if you are losing charge. We just swapped one out during a storm in an autozone parking lot.
     
  10. Crash935

    Crash935 2000 Club Member
    Messages: 2,377

    What is it doing now that you changed the valve out?

    Have you downloaded or read the mechanics guide yet, there is a flow chart that will walk you right through each step?
     
  11. ajordan193

    ajordan193 Senior Member
    from WNY
    Messages: 224

    I have power going from the truck to the plow but the motor isn't running. I just pulled off the entire pump so i can take it to have tested tomorrow to see if i fried the motor. After changing the valve the plow worked better and held an angle fine, but was still not 100%. The motor seemed to spin a lot more than it should and was still a little slowing angling. I have check the mechanics guide and went through a few of the steps...first thing i want to find out is if i need a new motor and have to rebuild the pump. I'll keep everyone updated. Thanks