1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8.2V Light Problems on Chevy

Discussion in 'Boss Plows Discussion' started by TWrench, Oct 11, 2009.

  1. TWrench

    TWrench Junior Member
    Messages: 21

    Just finished installing a Boss 8.2V wiring harness in my 2005 Chevy 2500HD. When I first tested it hooked up to the plow, I hadn't connected the wires to the turn signals and running lights. At that time, the low beams worked, but the left beam was very bright and the right was very dim. Once I hooked up the parking and turn wires, I lost the low beams on both sides. The high beams work fine when you turn them on, but I have no low beams. The switch position for plow or truck doesn't seem to matter either. To clarify, this all has to do with the truck lights, not the plow lights. Any help would be appreciated guys, Thanks!
     
  2. Deckscapes

    Deckscapes Senior Member
    Messages: 241

    New or used control kit harness? Are you using the correct Boss headlight adapter? You should have part # MSC04601 if you have the 4-lamp headlights with replaceable bulbs
     
  3. TWrench

    TWrench Junior Member
    Messages: 21

    After spending a fair amount of time searching the harness last night looking for issues and finding none, I decided to check fuses- sure enough, the low beam 10a fuse under the hood was blown- replaced it, all is good now. Feel pretty dumb, but at least it's fixed.
     
  4. Deckscapes

    Deckscapes Senior Member
    Messages: 241

    Good to hear! My next suggestion was going to be check all the headlight adapter connections as they have an "A" side and a "B" side and can easily be connected improperly.