1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

8.2 V RT3 won't stop running

Discussion in 'Boss Plows Discussion' started by MM&L, Nov 27, 2012.

  1. MM&L

    MM&L Member
    from So. MN
    Messages: 61

    Bought a used 2004 Boss 8.2 V plow 13 pin, I went to hook it up to one of our trucks and when I try to raise the tower with the toggle the pump runs and does not stop when you release the toggle. Stops when I unplug the power cable. Also the tower does not move an inch. Any help greatly appreciated
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Does it stick when using the controller too?
     
  3. MM&L

    MM&L Member
    from So. MN
    Messages: 61

    No doesn't do anything just the solenoid clicks I am going try a different truck and go from there
     
  4. MM&L

    MM&L Member
    from So. MN
    Messages: 61

    Brand new truck with new mount and harness does the same thing. I am thinking I should just put a new pump motor on it...any thoughts?
     
  5. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Go over the plow side power cables before doing anything. Make sure they're not loose at the motor and they're making good contact with the truck side connector.
     
  6. MahonLawnCare

    MahonLawnCare Senior Member
    from Ohio
    Messages: 852

    Those damn power cables give me fits on my older Boss plow too! I'd replace them. Start cheap before blowing hundreds on the motor, it's probably like B&B said, a problem with the power cable. Probably shorting out.
     
  7. MM&L

    MM&L Member
    from So. MN
    Messages: 61

    K I will check it out thanks
     
  8. MM&L

    MM&L Member
    from So. MN
    Messages: 61

    Looked it over everytime I move the toggle switch the pump starts and does not stop until I unhook the power cable
     
  9. MBB

    MBB Senior Member
    Messages: 129

    Well you have a short that is keeping the power solenoid energized. You also stated that it does not happen with the controller but only the mount/dismount switch I would suspect the switch as a start.
     
  10. MM&L

    MM&L Member
    from So. MN
    Messages: 61

    I found a valve stuck open, going to replace that. Checked all wires and grounds, they all seem good.
     
  11. MM&L

    MM&L Member
    from So. MN
    Messages: 61

    Replaced valve and changed fluid. Works like it should thanks for all the help
     
  12. Nytrojunkie

    Nytrojunkie Junior Member
    Messages: 1

    Do you by chance remember which valve was stuck open??? Having the exact same issue with my plow. Same plow as you also. Thanks!