1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

7 pin connector

Discussion in 'Truck & Equipment Repair' started by traviswalker007, Nov 17, 2006.

  1. traviswalker007

    traviswalker007 Senior Member
    Messages: 188

    My trailer lights wont work when plugged into my checy 3500. they work fine in my yukon with a 7 pin. I checked the voltage to the pins and am getting 12 volts, but when i plug in the trailer end nothing...i thought all 7 pin wireing was the same. it came on the truck when i bought it so i think checy installed it when i got the tow package. how can i troubleshoot this with out rewirng the trailer plug.
  2. LLM Ann Arbor

    LLM Ann Arbor Senior Member
    Messages: 876

    Corrosion on the trailer plug.

    Last edited: Nov 17, 2006
  3. plowinginma

    plowinginma Senior Member
    from MA
    Messages: 326

    could be a bad ground.. maybe the trailer hitch is acting as it ?? just an idea
  4. RYDER

    RYDER Senior Member
    Messages: 281

    Use a test light with the trailer hooked up.
  5. cincy snowdog

    cincy snowdog Senior Member
    Messages: 262

    there is a standard for the 7 pin where all locations are. get a test light and compare both trucks at same time,the pin location is marked inside the pigtail where you tighten the little screws for the wires.the problem comes from who hooked it up,did they use the coding or just as they wanted ,the biggest problem is the large ground wire,make sure you ground through the pigtail and not just by the hitch and ball,if nothing is on chance are its the ground but if you have trailer brakes and accessory power running through there you better get them on same page or you can have worse problems.look under the national code for the trucking industry to get the proper pin location ALSO DO NOT JUST GO BY THE WIRING COLOR ,check to make sure what it does.

    left turn and brake
    right turn and brake
    running lights
    power to trailer from brake box for axles
    clearance lights(usually only used on semi s not normal used on pick ups and such)
    power wire (for cargo lights or winch, possible brake battery charger or whatever needed on trailer)

    search under trucking wire codes ,or you can buy a pigtail and it will have the info inside .
    they also make a tester you can just plug and it will tell you what is wrong but you will have to fix it anyway so just learn the codes.also use what they call dyelecric grease ,do not use regular grease or w d 40
    good luck hope this helped.
  6. schuitb

    schuitb Member
    Messages: 95

    check the fuses

    Also you might want to check the fuses under the hood.. There are separate fuses for the trailer signals and so on..
  7. traviswalker007

    traviswalker007 Senior Member
    Messages: 188

    got 1 light

    ok, I pulled out the 7 pin and downloaded a wire diagram for a standerd 7 pin hook up, it looked like it was oposite of the original wireing. I cheked a couple of wires for power and only got a few at 12 volts, acording to the wire diagram i got, the yellow was left turn and green was right turn but only got a 12v hit off my meter on the green?? I wired it all up to what the diagram said and pluged the trailer into it, not hooked up, and I only got one light to work, the right side tail light and nothing else. My 96 yukon was wired up at the trailer shop so i am guessing its right since my trailer lights work, so whats up with the 03 chevy. what am i doing wrong, is the wire code the same or did they change it, I have black, white, yellow, green , blue and orange

    acording to the diagram, orange is the Aux, blue is the eletric brake, black is power, white is ground and yellow and green or signals........what am i missing here. my last experience with eletrical was not a good one if you read my pervious "im an Idiot" post..