1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

7.5 snoway with down pressure

Discussion in 'Sno-Way Discussion' started by Blazerboy, Feb 24, 2007.

  1. Blazerboy

    Blazerboy Junior Member
    Messages: 21

    Hey guys I just received a 7.5 snoway with down pressure and all it wants to do is angle to the right? wont lift, go down, or angle left any ideas and how much is this used unit worth. i just want to fix it and sell it. Any ideas would be helpful.

    SGTPOOL Member
    Messages: 30

    Call Steve At Snoway Tech. 1-262-673-7200

    He Can Walk You Through A Series Of Tests To Figure Out If The Soleniods(sp) Are Working Properly. He Had Be Back Up In Running Quick. If You Read The Inside Cover Of Your Plastic Motor Cover It Will Tell You Which Modules Need To Be Active During Which Operation. While Trying That Operation, Ie Up, Down Left Right Place A Screw Driver On The Medal Part At The Top Of The Soleniod And It Should Be Magnetic. Also Check To Make Sure That All The Wires Are Connected. They Can Easily Come Off. Also There Are 2 Fuses Inside The Cover Check Them.
  3. vwovw

    vwovw Senior Member
    Messages: 190

    in the long run your best bet is to:rolleyes: just give it to me
  4. Donny O.

    Donny O. Senior Member
    Messages: 410

    I jsut had that happen to mine on monday, but it would only go left. i'm sure i'm not using the corect terms for things and i apologise for that. i removed 1 of the 2 'actuators' on the sides of the manifold and cleaned it. there is a plunger in there that pushes out a hex shaped pin(careful this is not connected and will fall out) you can push the plunger from the end of the 'actuator'(little hole in the end), and at first it pushed real hard....so i cleaned with brake cleaner then sprayed with wd40 and worked it back and forth for a while. then with the 2nd one I didn't even remove it jsut poked my punch in the little hole on the end and moved the plunger and then the plow all worked good again. I think the 2nd one was stuck. i can get pictures if you want....not sure if mine is the same set up as yours but you can call me if you wnat me to try and explain it better while your looking at it as well. i'm no expert but we have the same trouble and i fixed mine!!

    Donny O.
    608-290-2214....anytime 24/7