1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

7.5 mpg!!!

Discussion in 'Ford Trucks' started by snowman91, Mar 25, 2011.

  1. Had a missfire in cylinder 2 I replaced the coil and all of my plugs and boots as well as my idle airflow control and now my truck is only getting 7.5mpg I usually get around 10.8mpg. I have no clue what's wrong any help is appreciated
  2. Its an 01 f250 with the 5.4
  3. grandview

    grandview PlowSite Fanatic
    Messages: 14,609

    I think it's the ****** winter blend gas they push on us. My mileage is not that much better in my 02 and 08
  4. Holland

    Holland Senior Member
    Messages: 605

    Still mising on 2? What plugs did you put in?
  5. The service engine light is off n I replaced all the plugs with motorcraft plugs
  6. wizardsr

    wizardsr PlowSite.com Addict
    Messages: 1,538

    Lay off the go pedal. Thumbs Up
  7. Pinky Demon

    Pinky Demon PlowSite.com Addict
    from Ohio
    Messages: 1,121

    Hold up here. How many miles? When is the last time you did routine maintenance?
  8. 75000 on the truck n maintenance is done every 3000. Just did plugs boots replaced the iac and cleaned the mass airflow sensor
  9. CornerStoneProp

    CornerStoneProp Senior Member
    Messages: 222

    That is what my 2009 f250 reg cab 8' bed gets with the plow on it. This is what the dash says, not calculated....
  10. Its what I'm getting w/o the plow
  11. matts27

    matts27 Senior Member
    from CT
    Messages: 138

    When was the last time an O2 sensor was changed? Probably got 4 or 3 on the truck. When they get close to their service limit they'll still function enough for the computer to think that they're okay but the responses aren't their and fuel mileage will suffer. Also, did you reset the computer by unplugging the battery? I think 30 seconds at least to start the computer back to learn mode.
  12. Ill try resetting the computer then the o2 sensors thanks
  13. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    The before cat"s are the ones you replace.