1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

7.3 Cuts off and on while driving?

Discussion in 'Ford Trucks' started by tugboat609, Jan 15, 2012.

  1. tugboat609

    tugboat609 Member
    Messages: 55

    I have a 2002 F250 with the 7.3. Last night was coming home and truck shut off while doing 45mph and immediately started back up. First and only time this has happened. Truck has 129000 on it. Any ideas fellows?
     
  2. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,677

    Would have the High Pressure Oil Pump checked out. Also make sure it is full of oil.
     
  3. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,975

    either the cam position sensor,or the gas pedal.....but more than likely its the cam sensor. do a search and theres a tsb on it, maybe even a recall.....i even got a class action lawsuit in the mail about it. theres 2 different colors,,1 is the old bad one,,1 is the new updated one. and if you have a scanner that would throw a code that you could check.
     
  4. tugboat609

    tugboat609 Member
    Messages: 55

    If it threw a code the check engine light would be on right? No check engine light is lit.
     
  5. deicepro

    deicepro PlowSite.com Addict
    Messages: 1,124

    Cam sensor!! I always carry a spare!!
     
  6. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,975

    no it is NOT considered a hard fault!!!!!!!!!!
    thats why i suggested to scan it if you had access to one
     
  7. Mark13

    Mark13 PlowSite Fanatic
    Messages: 5,737

    Look at your CPS. If it's gray it's the new one, if it's black its the old one. Slap a gray one in there and your off and running again.
     
  8. BPS#1

    BPS#1 2000 Club Member
    Messages: 2,407

    Changing the cam sensor is a 20 to 30 minute drive way fix.
     
  9. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,975

    thanks mark,,i couldnt remember the correct colors
     
  10. tugboat609

    tugboat609 Member
    Messages: 55

    Thanks guys! Now gotta locate the sensor.
     
  11. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,975

    right above and to the pass side of the balancer....10mm bolt
     
  12. tugboat609

    tugboat609 Member
    Messages: 55

    Cool thanks
     
  13. deicepro

    deicepro PlowSite.com Addict
    Messages: 1,124

    ???? The first time, maybe...
     
  14. NBI Lawn

    NBI Lawn PlowSite.com Addict
    Messages: 1,797

    Probably obvious but did you check your battery conntections? I had the same type of issue with my vette... lights would flicker and then come back. Turned out to be the battery was loose.
     
  15. BPS#1

    BPS#1 2000 Club Member
    Messages: 2,407






    I've only had to change one.
    It was 20 to 30 mins including getting the tools out and putting them away.



    What are you getting at?
     
  16. deicepro

    deicepro PlowSite.com Addict
    Messages: 1,124

    Oh, well when you put it that way. Should only take 10 minutes to swap out once you've done it before.
     
  17. BPS#1

    BPS#1 2000 Club Member
    Messages: 2,407






    I agree.



    That 20 to 30 may have included helping myself to a cold one from the fridge.
    Or was it 3? :laughing:
    Back in those days I had a much "healthier" thirst than I do now.
     
  18. tugboat609

    tugboat609 Member
    Messages: 55

    Okay so I called Ford about a recall on the camshaft position sensor. They told me my truck was not included in the recall which I thought strange. So I called another dealer and got the same result. So I bought one and installed it. The old one didn't look that old. The new and old were both grey. Guess we will see how it works out.
     
  19. dieselss

    dieselss PlowSite Fanatic
    Messages: 10,975

    That is odd. Did you give your vin for them to run and see if it had any recalls tho?
     
  20. tugboat609

    tugboat609 Member
    Messages: 55

    Yeah gave the vin and they said just a cruise control wire was the only recall performed. None other done or pending. Can't understand because my father has the same year truck and he has gotten the recall notice in the mail.