1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

7 1/2 Fisher RD Troubleshooting

Discussion in 'Fisher Engineering Discussion' started by backcountry, Nov 21, 2011.

  1. backcountry

    backcountry Junior Member
    from USA
    Messages: 10

    I have a 7 1/2 RD that I am mounting to a 2006 Chev 2500HD. I have the 26351, 26352, 26345 and 26357 harnesses plugged into a 4 port 27781 light green label.

    I cannot get the turn signals to work on the plow and the Fish Stick does not operate or light up.

    I have a new motor relay, the module is good, my wiring is correct to all light plugs as well as the purple directional wires and brown marker and pink DRL. I have power to the Fish Stick harness via a keyed source in the inside fuse panel with verified power.

    All the grounds are good and verified.

    Any ideas on what the issue might be? Any help would be appreciated.
     
  2. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    check the fuses under the hood 15 amp park/turn 7.5 amp controller out of port 1 of the isolation module
     
    Last edited: Nov 21, 2011
  3. backcountry

    backcountry Junior Member
    from USA
    Messages: 10

    Both fuses are good.
     
  4. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    Do you have an inline fuse with your power wire to a switched accessory?
     
    Last edited: Nov 21, 2011
  5. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

  6. backcountry

    backcountry Junior Member
    from USA
    Messages: 10

    It is a 3 plug to plow. An inline fuse is installed and power is going to the controller. The controller is basically new so it seems to be missing something else.
    Wired per Lit. No. 43226 Rev. 00
     
    Last edited: Nov 21, 2011
  7. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

  8. backcountry

    backcountry Junior Member
    from USA
    Messages: 10

    Thanks

    On the driver side I have brown to brown on the signal (yellow bulb), purple to blue on the signal (yellow bulb) and pink on the blue of the DRL.

    On the passenger side I have purple to the blue of the signal (yellow bulb).

    Does that sound correct vs. your setup?
     
  9. backcountry

    backcountry Junior Member
    from USA
    Messages: 10

    Looks like no solution here for this. Thanks for trying.
     
  10. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Do the park lamps work on the plow and do the headlamps switch over to the plow?

    How and where exactly did you verify power to the controller?
     
  11. backcountry

    backcountry Junior Member
    from USA
    Messages: 10

    The headlamps switch over both high and low beams. The park lights/signals do not.

    I verified power to the red accessory wire on the harness the controller plugs into. I went to the inside fuse panel and connected using a fuse-able link. Also has an inline fuse. Power exists beyond the inline fuse.

    Also replaced 7.5 amp fuse and 15 amp fuses to be sure they were not the cause.

    Thanks
     
  12. LON

    LON Senior Member
    Messages: 749

    Which headlights? 8435 used an external ground.
    Verified 12V @ your power wire?
    Headlights plugged into 3 & 4 in 4-port module?
    Power wire connected to the right side of the relay?
     
  13. backcountry

    backcountry Junior Member
    from USA
    Messages: 10

    64100 Lights
    Have 12V at Power
    Short and long headlight harnesses at 3 and 4 on module
    Power From Battery on one large relay terminal
    Power to plow on other large terminal
    Orange and black on one small terminal and red and black on the other small terminal

    Taking to Dealer on Friday morning.
     
  14. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    Alright backcountry I looked at my harness and this is how mine is setup.

    Drivers side truck harness plugs into the plow harness with the blue and yellow wires.Yellow goes back to plow harness blue goes to the headlight bulb with the orange wire.
    Drivers side truck high beam harness plugs into the green and blue plow harness,both go back to the plow harness
    You should have 3 splice wires.
    Purple splices into the turn signal
    Brown to Brown into the turn signal
    Pink splices into the blue DRL wire

    The passenger side all the harnesses plug in the same and the purple splice wire splices into the blue turn signal wire.
     
  15. LON

    LON Senior Member
    Messages: 749

    Where is the isolation module power wire connected to the relay at? It has to be on with the power cable from the battery @ the relay.

     
  16. backcountry

    backcountry Junior Member
    from USA
    Messages: 10

    Thanks for the help Guys. The issue wound up being one of the female pins on the harness side of the control plug in.