1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

5.4 engine sluggish

Discussion in 'Ford Trucks' started by ids, Oct 21, 2007.

  1. ids

    ids Junior Member
    Messages: 9

    i have a 5.4 v8 1999 with 110 000 miles. the problem is when i start it, its fine for a few minutes when it warms up it idles rough and when put under load it is sluggish and chuggs. can it be a fuel problem, filter maybe carb. engine light is on. thanks
     
  2. NBI Lawn

    NBI Lawn PlowSite.com Addict
    Messages: 1,797

    Its a Ford :D .

    Seriously though it sounds like it could be the fuel psi regulator. It starts fine though?
     
  3. mike psd

    mike psd PlowSite.com Addict
    from pa
    Messages: 1,028

    do a scan chances are it will point in the general direction . does it happen all day long or just first thing warming up
     
  4. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    Take it to an Auto Zone they scan for free in the hope you will buy the repair parts from them. They can give you the code and tell you what it means and the parts involved to repair it. Some of the repair shop in a can stuff can work too---> (fuel system cleaners).
     
  5. Diesel Sniffer

    Diesel Sniffer Member
    Messages: 46

    Sounds to me like your fuel pump might be starting to go. I've replaced many over the years and alot of them displayed the same traits you are describing.
     
  6. CARDOCTOR

    CARDOCTOR PlowSite.com Addict
    Messages: 1,310

    could be coil over plug

    JR
     
  7. bspan27801

    bspan27801 Junior Member
    Messages: 5

    Have you changed your fuel filter? If that is clogged or dirty that will also cause sluggish power. The same thing happened to me and I thought that it would need alot of expensive stuff and all it was was the fuel filter. Make sure you have a clean air filter too. Good Luck Hope it helps!!
     
  8. f250man

    f250man PlowSite Veteran
    Messages: 3,124

    Have a scan run on it sounds like a bad coil pack to me had the same problems and it was a few coils. Have you done a spark plugs change yet? If not it is about time for that to. I'm in the process of doing the head gaskets on my 5.4 with 160,000 on it and mine is sluggish to hope the new timing chains fix that. They are real lose. Hope this helps Steve
     
  9. EaTmYtAiLpIpEs

    EaTmYtAiLpIpEs 2000 Club Member
    Messages: 2,607


    Your not the only one with head gasket issues. I am having them done. But I had a bunch of different issues. Running rough on startup for a minute or so. Skipped. Loss of heat. Over heating. a quick marble sound on startup. And I own a 2003 f-250 with 126kmi on it.
     
  10. f250man

    f250man PlowSite Veteran
    Messages: 3,124

    I'm doing mine myself saving a hole lot of money. Most places want 3000-4000 to do it. I have spent about 600.00 to do it my self. Steve
     
  11. EaTmYtAiLpIpEs

    EaTmYtAiLpIpEs 2000 Club Member
    Messages: 2,607

    without the machine work he wanted $650 plus abother 200 to have the heads shaved and stuff.