1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

4x4 Problem on Ford Excursion

Discussion in 'Ford Trucks' started by jjfinn, Feb 8, 2011.

  1. jjfinn

    jjfinn Member
    Messages: 56

    I have a 2000 Ford Excursion the dash shows that the 4x4 is on but I can only get anything from the rear wheels, I can see the axle spinning but nothing out of the tires. This is the first Ford I have ever owned and I am kinda lost. Any help would be greatly appreciated. Thanks
     
  2. abbe

    abbe Senior Member
    from RI
    Messages: 719

    is it a dash switch 4x4? vacuum hubs could be bad
     
  3. jjfinn

    jjfinn Member
    Messages: 56

    Yes dash switch
     
  4. cretebaby

    cretebaby PlowSite Veteran
    Messages: 4,162

    Lock your front hubs manually then try it.
     
  5. jjfinn

    jjfinn Member
    Messages: 56

    Tried locking manually still nothing.
     
  6. cretebaby

    cretebaby PlowSite Veteran
    Messages: 4,162

    Now with the hubs locked take it out of 4 wheel and see if the front U joints are turning.
     
  7. KBTConst

    KBTConst Senior Member
    Messages: 426

    Shift motor on transfer case is my guess!
     
  8. jjfinn

    jjfinn Member
    Messages: 56

    okay I got frustrated and took it into the shop today. They told me its the hub seal and a broken u-joint. They never gave me a price on the fix does anyone know is this a expensive fix?