1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

4x drive shaft ?

Discussion in 'Ram Trucks' started by vmj, Dec 28, 2013.

  1. vmj

    vmj Senior Member
    from conn
    Messages: 752

    Stupid question..... I have a 00 3500 ram should front drive shaft spin freely when in 2x
     
  2. rjigto4oje

    rjigto4oje PlowSite.com Addict
    Messages: 1,285

    if I remember it does I have 2 does 4x4 work any issues
     
  3. vmj

    vmj Senior Member
    from conn
    Messages: 752

    I was just replacing switch on 4x and tried to turn it.. 4x is working...
     
  4. rjigto4oje

    rjigto4oje PlowSite.com Addict
    Messages: 1,285

    I'll check in the am I I forget pm me
     
  5. vmj

    vmj Senior Member
    from conn
    Messages: 752

    thanks you
     
  6. NicholasMWhite

    NicholasMWhite Senior Member
    Messages: 175

    yes it should
     
  7. quigleysiding

    quigleysiding PlowSite.com Addict
    Messages: 1,097

    just checked mine It does
     
  8. rjigto4oje

    rjigto4oje PlowSite.com Addict
    Messages: 1,285

    Someone beat me to thanks guy don't have to lay under the truck now
     
  9. vmj

    vmj Senior Member
    from conn
    Messages: 752

    thanks guess I have and issue!!!
     
  10. vinnys

    vinnys Senior Member
    Messages: 112

    Make sure you put it back together correctly. Shift fork has to ride in the shift coller. Make sure the fork moves freely when you apply vacuum. If the coller is engaged with the axle shafts, the driveshaft will not turn.
     
  11. Snow Commandor

    Snow Commandor Senior Member
    from 07666
    Messages: 439

    Yes it should! does yours spin freely or not?
     
  12. vmj

    vmj Senior Member
    from conn
    Messages: 752

    no.. shifter is in 2x on floor. it does feel like its going in and out of 4x
     
  13. rjigto4oje

    rjigto4oje PlowSite.com Addict
    Messages: 1,285

    Maybe linkage problem
     
  14. vmj

    vmj Senior Member
    from conn
    Messages: 752

    just got in from buddys garage, and it was the vacume diafram on front axel that went bad...
     
  15. Snow Commandor

    Snow Commandor Senior Member
    from 07666
    Messages: 439

    Ok that make sense. and that shouldn't be to expensive to replace.
     
  16. quigleysiding

    quigleysiding PlowSite.com Addict
    Messages: 1,097

    Had to replace mine. Coudnt get just the diaframe though. Had to buy the whole thing. Think it was $250 or more. Only place that had it in stock was the dealer.
     
  17. Snow Commandor

    Snow Commandor Senior Member
    from 07666
    Messages: 439

    Yeah, I'm pretty sure that's a dealer only item.
     
  18. vmj

    vmj Senior Member
    from conn
    Messages: 752

    great............
     
  19. vinnys

    vinnys Senior Member
    Messages: 112

    Napa should have them.
     
  20. Snow Commandor

    Snow Commandor Senior Member
    from 07666
    Messages: 439

    not electrical but vacume.