1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

4L8OE Tranny Problems(4th gear)

Discussion in 'Truck & Equipment Repair' started by 2000NPRIsuzu, Feb 11, 2016.

  1. 2000NPRIsuzu

    2000NPRIsuzu Junior Member
    Messages: 3

    Hello Everyone, I have a 2000 Npr Isuzu with a chevy 5.7 and a 4l80e transmission.

    My problem is when the truck gets warm after 20 mins of driving, it will pop out of 4th gear and won't shift back in it. I have checked fluid and that is fine. What can I check without having to take it to the shop. anything?

    Is this a electrical problem or tranny problem? it shifts like a new truck when its not warm, then when it pops out shifts like crap! can anyone help with things to check, i can't even drive across town with anything in the truck. fluid is red and ok not burnt i don't think so, with no codes and have check and still nothing comes up.

    Snow is falling here and trying to get going! Any help will be very helpful. Thank You
     
  2. johnhenry1933

    johnhenry1933 Senior Member
    Messages: 256

    Welcome to the form 2000!

    Not much.

    That is a tough transmission. When rebuilding I would toughen it up with a shift kit, heavy duty bandings, and maybe a few other things.

    Else, go on the cheap and have repaired whatever is worn.
     
  3. 2000NPRIsuzu

    2000NPRIsuzu Junior Member
    Messages: 3

    Thanks for the reply,

    Do you know if there are any external relays or anything i can check before dropping the pan. I don't have downtime for this truck to be sitting. Does anyone ever heard of this and what would you change out first.

    Im trying not to rebuild because i think there is nothing wrong with this. i think it is electrical but have no clue what to check because I am new to this truck.

    If I turn the key off in neutral and coast down a hill, turn it back on and for a few mins it will go in 4th again but then it will pop back out to 3rd.

    Any help would be great, thanks everyone!! :help:
     
  4. johnhenry1933

    johnhenry1933 Senior Member
    Messages: 256

    I don't believe anything is external. As long as the fluid is correct and up to snuff (good flow), you have an internal issue. (solenoid, band, clutch, etc.).

    I rebuilt mine w/ some hd mods and it plows like a dozer.
     
  5. bmc1025

    bmc1025 Member
    Messages: 36

    It is kicking out of 4th most likely from the torque converter not locking. It can be as simple as the tcc solenoid being bad or not getting power (not likely) the o-ring on the input shaft being split, bad converter, or od clutch pack.

    It will be fine to run in 3rd until you have time to get it repaired. You could also just leave it as a 3 speed.
     
  6. 2000NPRIsuzu

    2000NPRIsuzu Junior Member
    Messages: 3

    Ok, thank you everyone, Im still trying to figure this shift out, I just changed the temp sensor, tps, nothing still the same. thought it was a misfire so i changed plugs and new plug wires. Drained some fluid to make sure the line is right on dip stick. Nothing, Trying to not open tranny at this time. I truly think this is something stupid because it just started and getting worst.

    So, I found the my Bank 1 sensor 2 was rubbing on frame and two wires are showing copper. Can this affect my tranny in any way. I plugged up code reader and it show n/a on that one, so its a bad o2 does that affect my shifting and going into limp mode when warm??? truck does Not show any codes or no check engine. Any help on this?? anyone know about these npr's? Thank you everyone!!

    where are the ground wires on a 4l80e and how many should there be??
     
  7. Mr.Markus

    Mr.Markus PlowSite Fanatic
    Messages: 5,169