1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

4L80E Shift problem?

Discussion in 'Chevy Trucks' started by bassfishn1, Mar 4, 2008.

  1. bassfishn1

    bassfishn1 Member
    from ct.
    Messages: 30

    ok, here is the deal, had this tranny rebuilt at about 175,000 miles, no problems so far, except today. serviced regularly, treated gentle, don't plow, keep it under 100 mph at all times.

    so, today, started driving, hit 2nd, hard shift, never shifted like this before, then 3rd, bang, hard shift, not a BANG, but a bang like i was racing, very firm i should say. all the shift points were correct.

    when the tranny was rebuilt, the guy said he put in a shift kit?, but still, never shifted like this before.

    so, now it does not do it anymore, only did it that one time on a short run, shut the truck down, restarted it about 20 minutes later, and back to normal.

    no trouble codes came up, so i am baffled, anyone know what might of happened?, or what's about to happen? any help would be greatly appreciated
     
  2. Spitz

    Spitz Senior Member
    Messages: 192

    Maybe the accumlator piston got hung up some how.. Its just a spring loaded piston to help soften the fluids force.. Just a guess...
     
  3. bassfishn1

    bassfishn1 Member
    from ct.
    Messages: 30

    tnnnnnnnnx