1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

4l80 prob

Discussion in 'Truck & Equipment Repair' started by plower11, Feb 1, 2014.

  1. plower11

    plower11 Junior Member
    Messages: 7

    hi guys looking for some help with 95 chevy. I cant seem to get this trany prob figured out. it is a 4l80 e reman jasper 2 months old I get code 81 82 83 and wont shift right only seems to do it when warm and after shuting it off after it cools down seems to go away I can clear codes with scan tool and start back up and sometimes it will set codes sometimes not any help would be nice thanks plower11
     
  2. myzx6

    myzx6 Member
    Messages: 90

    Did u flush or replace tranny lines and cooler, sounds like a possible plugged filter if any debris remained in cooler
     
  3. Whiffyspark

    Whiffyspark 2000 Club Member
    from SOMD
    Messages: 2,402

    That's under warranty. Jasper will replace teams
     
  4. myzx6

    myzx6 Member
    Messages: 90

    Agreed, jasper is really good about warranties, should there be something internal that has failed
     
  5. plower11

    plower11 Junior Member
    Messages: 7

    4l80e prob

    yes ran a hot flush on lines and cooler just seems funny that doesn't do it all the time so im thinking something electrical or pcm is hard to find this cause doesn't do it all the time
     
  6. Whiffyspark

    Whiffyspark 2000 Club Member
    from SOMD
    Messages: 2,402

    Like I said jasper will replace trans free of charge.

    If you really want to fix it Youre going to need a scanner that can do live data. It sounds to me like it may be a valve body problem.
     
  7. kimber750

    kimber750 PlowSite Veteran
    Messages: 3,691

    Ignition switch is known issue. A replacement power relay is made to combat this issue. Need to check the 12v source on the tranny plug.