1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

4L80 E question

Discussion in 'Chevy Trucks' started by snowjoker, Apr 10, 2003.

  1. snowjoker

    snowjoker Senior Member
    Messages: 283

    I have a 93 2500 Chevy, the problem is that cruising down the road and the engine will rev up and the speedometer will fluctuate about 10 mph.It does not slip at all any suggestions? i feel it is some kind of sensor,just don't know what one. :eek: one maybe speed sensor? any help would be greatly appreciated

    Walt
     
  2. wyldman

    wyldman Member
    Messages: 3,265

    It certainly sounds like it's slipping.When the revs go up does the speedo go down ?

    Maybe your feeling the torque convertor clutch unlocking ? Stepping on the brake pedal when cruising will unlock the TCC so you can see what it feels like.
     
  3. snowjoker

    snowjoker Senior Member
    Messages: 283

    the check engine light comes on also it will run ok for a bit then it will start doing it again.the transmission will shift perfet when accelerating no slippage there will the torq converter cause this? i never had this prolbem before
     
  4. snowjoker

    snowjoker Senior Member
    Messages: 283

    wyldman yes the speedo goes down i just changed the fuel filter and took it for a ride and the speedo goes down what does that mean a sensor?
     
  5. wyldman

    wyldman Member
    Messages: 3,265

    If the speedo is dropping or going down and the truck revs up,then it is either slipping,or loosing power and downshifting.

    If the truck seems to be running good and pulling hard,but the revs go up,and the truck speed drops off,then i'd have to say the trans is slipping.Check the TV cable to make sure it is connected and adjusted properly.Check the fluid condition and level,as wll as the shift linkage adjustment,to make sure it's going into gear properly.

    If you feel the power drop off,or you can feel some sort of downshift,then the problem may lie elsewhere.May be a fuel pump losing pressure,or a plugged catalytic convertor.

    Your going to have to figure out if it's the trans or the engine.

    First thing to do is throw a scanner on it and pull the codes,to find out why the check engine light came on,these codes may help decipher the problem,or at least point you in the right direction.
     
  6. snowjoker

    snowjoker Senior Member
    Messages: 283

    thanks for the heads up. i will hafto see if one of my friends that is a mechanic for a local gm dealer will look at it for me because the truck runs strong and i just serviced the tranny about a month ago.
     
  7. John DiMartino

    John DiMartino PlowSite.com Veteran
    Messages: 2,154

    Like Chris said,put a scanner on it. I think you have a speed sensor problem.You definitely have an electrical problem,from either a speed sensor or an engine speed sensor. Since the speedo floats around.I can guess pretty safely the VSS is bad or has a wiring problem. The 4L80E does not use a kick-down cable,so don't go crazy looking for it:D