1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

4L60 E Tranny Problems

Discussion in 'Chevy Trucks' started by VR6 Eater, Nov 14, 2002.

  1. VR6 Eater

    VR6 Eater Junior Member
    Messages: 3

    I have a 94 Chevy cheyenne. I started having problems last week with the tranny not making up it's mind while driving. If I drive about 15 miles it will shift out of OD or D, depending on speed, and will shift into second gear. I think at highway speeds it will shift into D but, I haven't had the balls to take it on the tollway since this started happening. It did it for a week straight, to and from work. I let it sit for 3 days and then drove it on 3 seperate trips with no problems, totalling about 150 miles. The truck has 246,??? miles on it. Tranny was rebuilt 1 1/2 years ago, 20,000 miles on it. I never had a problem with it until know, besides the slipping just before it got rebuilt. Does anyone have any ideas????? I heard that the tranny is all computer controlled. Is it a seperate computer??
     
  2. plowjockey

    plowjockey PlowSite.com Sponsor
    Messages: 622

    I had a '91 S-10 with the overdrive trans. Started losing OD and it wasn't long before they had to replace everything in the case.
    Have you checked your fluid for sparkles of metal?

    Bruce
     
  3. VR6 Eater

    VR6 Eater Junior Member
    Messages: 3

    I checked the fluid and it looked good. I replaced it a couple of months ago and it looked good then also. It already got rebuilt a little over a year ago. But as usual with my luck, it started screwing up just after the warranty expired.
     
  4. russ130

    russ130 Senior Member
    Messages: 204

    Assuming all things are right it sounds like a pressure issue. However to be truthful it sounds more like a linkage misadjustment to me. Readjust your linkage and tv cable and see if it still happens. If it does, time to bring it to the doctor for a checkup.
     
  5. VR6 Eater

    VR6 Eater Junior Member
    Messages: 3

    Well I was really hoping that someone had come across this problem before. I am going to try and put a tranpak kit in it. It's cheaper than a rebuild. I was thinking of the pressure issue, I was hoping that the shift kit would do enough to the valve body that if it was a pressure issue it would help. At least when I have the valve body out I can see what's going on in it.

    Is the indicator switch in the transfer case hooked up to the computer at all? I had that go out on me years ago. I didn't think that could all of a sudden cause this problem. I should replace it anyways. Does anyone have an idea on what the price is on one?

    If I ever figure out what the problem with this thing is I'll post it for future reference.