1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

351 engine ping

Discussion in 'Ford Trucks' started by chas4x4, Feb 15, 2003.

  1. chas4x4

    chas4x4 Senior Member
    Messages: 101

    Anyone have a problem with the ford 351 and engine ping on hills or with hard take off.I have cleaned the injectors checked fuel pressure changed air filter fuel filter just changed o2 sensor because of a lean code it kicked out.It seems to cruise ok till i hit a long grade,Iwanted to ****** the timing but it is computer controlled.The truck is F-250hd 1997 it only has 42,000 on it,begining to think that this is not the best investment after seeing all the front end problems.I have only had this truck for 8 months and have always had fords.
  2. noclevername

    noclevername Member
    Messages: 30

    Have you tried the knock sensor? It should back the timing off when it senses detonation. We have a '97 F250 as well but it's a PSD. Haven't had any front end problems, but we run Firestone air bags in them as well as putting in zerk fittings. Did you try a higher grade of fuel, maybe some more octane will help.
  3. sno-mover

    sno-mover Senior Member
    Messages: 274

    Sounds like bad gas.
  4. chas4x4

    chas4x4 Senior Member
    Messages: 101

    351 ping

    I tried all grades very little difference.I have not found a listing for a knock sensor on this engine,unless it is call something else. I thought it might be the computer but the truck starts and runs good other wise.
  5. CT18fireman

    CT18fireman Banned
    Messages: 2,133

    Have you replaced the plugs, wires and such, a full tuneup???

    Standard or Automatic???

    On a standard expect a bit on a "hard" take-off in low gear. If you look under the hood at all the emissions controls you will see why. Lots of hoses and wires to keep that engine in emission specs.
  6. flakesmeangreen

    flakesmeangreen Senior Member
    Messages: 217

    Sounds like a problem I had. Have a '97 250HD w/ 351. Didn't always make the sound but usually did it under any type of load. Turned out I had a hairline crack in the exhaust manifold. Sure sounded like something else.

    As far as the front end I hear you there! Tires get worn out too quick with the IFS, ball joints, shocks, u-joints, hubs, etc. ( I forget what else right now). Put Timbrens on in January. They really do help with the plow; we'll see if there are really any benefits related to the suspension.

  7. bwamx

    bwamx Member
    Messages: 30

    The plug wires always fry on the Ford V8's as they run so hot.
    Also check the sparkplug wire routing, as the fords can
    run ito misfiring on the 302's& 351's .
    Also check the vaccum line to the EGR valve and elect connections.
    The sensor on the EGR also is used to control the engine timing.
    I don't belive the engine has a knock sensor.

    Check out this forum :

    Lots of help and a good Msg Board also.

    Hope this helps.
    Last edited: Feb 16, 2003
  8. chas4x4

    chas4x4 Senior Member
    Messages: 101

    351 ping

    It's an auto I put new plugs dist. cap&rotor haven't changed wires yet,I'll check the electric part of the egr.didn't know it did that.thanks for the in put everyone