1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

3-1-09 storm ATV pics

Discussion in 'Storm Pictures' started by Steve G., Mar 7, 2009.

  1. Steve G.

    Steve G. Senior Member
    Messages: 155

    Hey guys, not a variety of pics but a few nonetheless. What a day! we were forecasted to get 7-13" (I know, I know.... all you guys upstate and in the rest of the country that get this normally are laughing) .... the machine pushed the heavy snow but not without a fight! When I had just finished the sidewalks the pin that hooks the quick connect from the plow up to the ATV either fell out or snapped... I dunno what happened to it, just noticed that the plow was 3 feet to the right of the quad when I went to plow again!
    Next I ran out of gas and it wouldn't start for about 10min, the whole day it was cutting off also, I need to adjust the carb to raise the idle.
    Then towards the end of the day the winch cable broke. Had to go to home depot and get a winch cable clamp. side note: saw a nice loader at homedepot

    enjoy


    [​IMG]
    [​IMG]

    [​IMG]

    [​IMG]
     
  2. Steve G.

    Steve G. Senior Member
    Messages: 155

    [​IMG]

    [​IMG]
    Loader at Homedepot:D

    [​IMG]
     
  3. Bibbo

    Bibbo Senior Member
    Messages: 121

    i had a sportsman 500 that i used to plow with and i loved it, it was great with the 26'' itp blackwaters on it but when i put the 27'' vampires on it it sucked in the snow lol, we changed the springs on the plow so it wouldn't trip so easy