1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2500hd sometimes won't start

Discussion in 'Chevy Trucks' started by TrailK10, Apr 15, 2008.

  1. TrailK10

    TrailK10 Member
    from NH
    Messages: 74

    I have an 02 2500hd yesterday i filled it up today it sat out in the sun and when i went to start it it would start and run for about a sec then die tried it a few more times and did the same thing waited 5 mins and it started. it has done this to me in the past I'm wondering if this maybe vapor lock? any suggestions?
     
  2. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    What engine? 6.0, 8.1 or D-Max?
     
  3. TrailK10

    TrailK10 Member
    from NH
    Messages: 74

    6.0 liter v-8
     
  4. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    Wouldn't be vapor lock...but it could be a multitude of other things.

    Need to start with the basics Trail...

    Has the security light ever been on when it starts and then stalls?

    Fuel pump running when you first turn the key to the run position?

    Need to check for fuel pressure.
     
  5. TrailK10

    TrailK10 Member
    from NH
    Messages: 74

    i have seen the security light flash but i dont know if it was at the time of it not starting it also has some wires hanging by the fuse box for a store bought remote car stater which is not being used that was put in by the first owner which could be the problem. i always hear the fuel pump when this problem ocurs
     
  6. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The remote start can definitely cause a problem such as this. You may want to start with verifying whether it's actually completely connected..or completely disconnected before you check other avenues. Either case can cause all kinds of starting issues with the factory security system.
     
  7. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    That passive security system got me the other day with my 2000 Malibu.
    I noticed the Security Light was on and looked it up in the owners manual. I didn't even know it had the system.
     
  8. ServiceOnSite

    ServiceOnSite Senior Member
    Messages: 935

    does the light still flash when it starts? is this starting hot or sitting cold?
     
  9. Brant'sLawnCare

    Brant'sLawnCare PlowSite.com Addict
    Messages: 1,754

    You may have a sensor problem, either a Camshaft or shaft sensor. I had that happen in my Dodge.
     
  10. ServiceOnSite

    ServiceOnSite Senior Member
    Messages: 935

    im thinking that he got it fixed
     
  11. MickiRig1

    MickiRig1 PlowSite Veteran
    Messages: 3,617

    That's a good bet since it was posted in mid April.