1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2011 Ford Headlight issue

Discussion in 'Boss Plows Discussion' started by rb69, Nov 20, 2011.

  1. rb69

    rb69 Member
    from Midwest
    Messages: 58

    I have finished wiring up a 2011 F-250 diesel superduty . Plow works fine and parking lights are fine, but truck and plow lights have me confused.
    I used Bosses headlight /relay kit for it. Truck headlights work and have had the plow lights working also, but not sure what I do, but they are not working correctly or sometimes not at all. I can hear the relays clicking at times, but lights aren't working as they should.


    Anybody have any of these problems when wiring the new trucks?

    Thanks
     
  2. rb69

    rb69 Member
    from Midwest
    Messages: 58

    update: It has something to do with the headlight switch.
    If you turn the headlights off and then back on everything works as it should.
    I thought I read some where that the headlights are run by the computer???
     
  3. B&B

    B&B PlowSite Fanatic
    Messages: 12,777

    The trick is to NOT switch between the truck and plow lamps with them on. Always make the switch with them off. It's a common issue on the newer trucks that use "smart lamps". Problem is they've become too smart for their own good when any kind of accessories are added.
     
  4. MikeRi24

    MikeRi24 Senior Member
    Messages: 563

    We just put a Boss on my friends brand new F250 and ran into this as well. And turning things on and off and flipping switches just makes things worse. We found that the only thing that straightened it out was to plug the factory connectors back into the headlights, turn everything off, and then disconnect the battery for a few seconds and everything should reset itself.