1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2008 Ford Ranger FX - Plow Install Questions.

Discussion in 'Truck & Equipment Repair' started by enolooc, Dec 3, 2010.

  1. enolooc

    enolooc Junior Member
    Messages: 4

    Hi to all on the site.

    Recently installed a new 7'6" Snow dog plow on my Ranger. At an authorized installer in Niagara Falls, New York.

    Had a set of Timbrens intalled in the front end at same time.

    Drove plow home to Toronto, ON, Canada. No issues.

    Stored the plow and continued driving the truck as normal.

    Have not used plow at all.

    4 weeks later.

    I began to notice a slight wobble/vibration at about 60 km's in the front end.

    Then a few days after check engine came on.



    Truck has 52,000 km on it. Bought in December 2008, new, from Ford dealer.


    Any suggestions on what might be causing the 2 problems?

    Thank you
     
  2. NicholasMWhite

    NicholasMWhite Senior Member
    Messages: 175

    I doubt it has anything to do with what they did. It is most likely just a coincidence. Take it to a shop or dealer and have them fix it. If they find something funny call up the shop who installed the plow and work something out.
     
  3. enolooc

    enolooc Junior Member
    Messages: 4

    Thank you. Was not sure what it could be. Your reply gives me more confindence to go to the dealer. It's still under warranty. So Not sure what the dealer will say after seeing the plow hook ups. Manual states warranty void if plow installed. But It shouldn't be related. Thanks again for the support. :)
     
  4. hydro_37

    hydro_37 PlowSite Veteran
    from iowa
    Messages: 3,790

    take it to the Ford dealer first....since you bought it new from them hopefully they will work with you
     
  5. the_experience

    the_experience Member
    Messages: 75

    Unless your "wobble" was an engine miss the check engine light and whatever you felt should be unrelated. The check engine light only comes on when a fault occurs that will cause emissions to exceed 150% of the certification levels for that particular year/make/model/options package. The plow would not do this unless they did some booty fab wiring it up and really made a mess of things.
     
  6. enolooc

    enolooc Junior Member
    Messages: 4

    Thank you for all replies. Will bring to Dealer. I am reaching end of warranty and I asked them to do a bumper to bumper warranty inspection. We'll see what comes out of it. Wiring looks pretty straight forward. And it was running fine for the past weeks since install. Hoping its a simple fix.