1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2006 Ram 3500, problem with lights

Discussion in 'Ram Trucks' started by Motorcityman, May 20, 2010.

  1. Motorcityman

    Motorcityman Junior Member
    Messages: 10

    My Plow truck is an 06 Ram 3500 diesel, I run an 8' Boss V plow which I also bought new in 06'. I'm having a problem with my head lights, only the highbeams work, when I click to low beams they don't turn on, if I have the fog lamps set to on they will turn on, ambers work fine. I checked all the wiring for loose connections and everything seems to be tight with all connectors in place. I thought maybe the bulbs went bad but I changed one with a new one and still no dice? Any suggestions before I take it to the dealer and get rapped, I know they will blame the plow harness, I'm thinking thats where the problem is comming from anyway. Thanks. Joe

    MIDTOWNPC PlowSite Veteran
    Messages: 4,413

    what happens when you disconnect the plow do your normal high and low work?

    any connections corroded - maybe give them a bit of dielectric grease, or fluid film?
  3. bltp203

    bltp203 Senior Member
    Messages: 484

    Bad Relay?????? Should be easy enough to check just swap them around.
  4. Motorcityman

    Motorcityman Junior Member
    Messages: 10

    This is with the snow plow removed from the truck, no external lights hooked up and the plow lights switch in the off position. When the plow light switch is on neither the high or low beams work on the truck as the plow lights take over.