1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2004 dodge 2500 no running lights or back up lights

Discussion in 'Ram Trucks' started by windrowsnow, Dec 10, 2011.

  1. windrowsnow

    windrowsnow Senior Member
    from nw ohio
    Messages: 168

    i have a 2004 ram with a western ultra mount three plug. i have headlights and brake lights, no running lights what so ever or back up lights, fuses work replaced bulbs, no wires look to be burned. is there something in the plow set up that could of went out? or a solenoid on the truck? or relay?
     
  2. UglyTruck

    UglyTruck Senior Member
    Messages: 210

    If none of the normal fuses check bad then check the 7 pin RV plug at the back. they have been known to short out and melt down.
     
  3. HEStufrthnnails

    HEStufrthnnails Senior Member
    Messages: 354

    I don't know if you've checked but on my Dodge I kept burning light switch's up. I found out later I had a tail light wire grounding out. It did just what you described. Lost all marker and tail lights.
     
  4. SNOW-BOSS

    SNOW-BOSS Junior Member
    Messages: 8

    Check the neutral safety switch on the side of the tranny. Just had mine replaced two weeks ago on my 01 Dodge 2500 because the back up lites werent working.
     
  5. windrowsnow

    windrowsnow Senior Member
    from nw ohio
    Messages: 168

    thanks guys, turns out it is the power module under the hood of the truck. took it to a mechanic