1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2004 Dodge 1500 Quad 4x4 Electrical help

Discussion in 'Ram Trucks' started by dss56, Dec 28, 2010.

  1. dss56

    dss56 Senior Member
    Messages: 118

    4.7 engine with 136 amp alternator.

    Was out in the storm plowing Monday and had the heater going and the wipers,plow lights and beacon going. When I had to control the plow I would get check gauges on the dash and the battery meter was all the ways back to 0 volts. This would not happen all the time but enough times for me to ask if there is a solution. This only happens when I have to up/down left/right the plow. It will recover if I let sit for 15 seconds and then back to 14 volts.

    The lights dim just a bit when this happens and the heater blower dips a bit also but not much.

    I'm thinking of getting a new battery maybe a 1000 crank amps and hope that would help or a deep cycle battery.

    I know I could get a bigger amp alternator but would that help I think a better battery would do better.

    Any suggestions. Are there any other dodge trucks that might have the 160 amp alternator that might fit my 2004 1500 4.7 engine? I could get a used one.
    Last edited: Dec 29, 2010
  2. 04ram1500

    04ram1500 Member
    Messages: 97

    I have the exact same truck except w/ the HEMI. Had the same problem Monday. I went to autozone and got the bigger alternator and a bigger battery. Fixed the problem. IMO head to autozone and pick up a new alt because it will be the last one you need. As they have a lifetime warranty, I believe the battery I got has a 5yr warranty. Everything cost me 250.00 out the door.
  3. Cromer_22

    Cromer_22 Junior Member
    Messages: 24

    I have a 04 hemi got the good alternator and the best battery and it still does it when i have the heated mirrors rear defroster and the heated seats on LOL