1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2004 5.7 hemmi idel speed?

Discussion in 'Ram Trucks' started by Snow Commandor, Feb 2, 2016.

  1. Snow Commandor

    Snow Commandor Senior Member
    from 07666
    Messages: 439

    My 5.7 hemmi ideas @ 500 rpm when in drive and the turn signal starts to flicker. Should the idle speed be that low? If I put it in neutral it idles around 600 and the flickering goes away.
     
  2. dodgegmc1213

    dodgegmc1213 PlowSite.com Addict
    Messages: 1,002

    I think you have another problem, my 04 5.7 idles at 500 rpm also but I don't get any flickering at all
     
  3. johnhenry1933

    johnhenry1933 Senior Member
    Messages: 256

    The idle is about right...525 rpm.

    Any codes? That's where I'd start.
     
  4. SnoFarmer

    SnoFarmer PlowSite Fanatic
    from N,E. MN
    Messages: 8,542

    X2 try a code reader, even if you don't have any codes,
    A decent one will show how a lot of the trucks syestems are functioning.

    Or get a k&n or a CIA,
    Woops never mind, your rpms will go down even farther if you do.
     
  5. scottr

    scottr Senior Member
    Messages: 360

    Flickering might be from corrosion on the bottom of your fuse panel under the hood. These years were known for this issue. My 04 started doing odd things with the tail lights and wipers. The fuse panel comes out pretty easy, there's a bit of work to pull it a part and access the circuit board where the corrosion can form. I was able to fix mine by cleaning and soldering some new trace over one circuit. ( or you can purchase a new one from dealer ) My research showed most that tried buying used (EBay ) were in the same shape. Hopefully this is not your problem, but somthing to look into if you can't find the issue.
     
  6. Snow Commandor

    Snow Commandor Senior Member
    from 07666
    Messages: 439

    I haven't had any codes until just the other day. The only code is for an o2 sensor. The low idea issue with the flickering has been an issue from the time when I bought the truck. And it has a no name K&N style air filter assembly.
     
  7. CARDOCTOR

    CARDOCTOR PlowSite.com Addict
    Messages: 1,310

    i had a few driveabily problems with my 04 all related to a bad o2 senspr
    including low idle and dead gas pedal . you can disconnect/reconnect the battery and see if it help with the idling or turn the defrost on which should give you a few 100 rpms