1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2003 2500HD no reverse

Discussion in 'Chevy Trucks' started by MrDeez, Jan 23, 2011.

  1. MrDeez

    MrDeez Junior Member
    from Midwest
    Messages: 22

    plowing last night, about 2 hrs in, no reverse.
    Forward is fine...shift to reverse sounds as if in reverse...no reverse.
    What is it?? How much??
    Thanks Fellas.

    P.S. 66,000 miles on truck.
     
  2. PTSolutions

    PTSolutions PlowSite.com Addict
    Messages: 1,533

    had reverse go out on our 02 when it had 30K, rebuilt trans under warranty.

    another rebuild last feb at 110K, cost 1800. whole trans was slipping this time.
     
  3. flykelley

    flykelley 2000 Club Member
    Messages: 2,124

    Broken Reverse band is pretty common on Chevys, mine did the same thing last year =. Last push of the night Im stacking the last bit of snow and on the pile and no reverse. Pulled the Trans and the ear on the reverse band was broken. Clutches and everything else looked real good so we put in a new reverse band and put it back together. Been a year now and no problems. Most guys will tell you to rebuilt the trans at the same time, but mine at 100K showed very little wear so we just replaced the reverse band.

    Good Luck Mike
     
  4. 2COR517

    2COR517 PlowSite Fanatic
    Messages: 7,115

  5. tac48

    tac48 Member
    Messages: 41

    More than likely something with the reverse band like mentioned. The band could be broke or burned. Also would not hurt to make sure the reverse servo piston did not brake before removing trans. I just had this same problem on my 03 K2500 a week ago. I replaced the trans with a spare one built just for this occasion this summer, to save time. Finally, got time to tear it down the broken one this week. I found the reverse band was burned, not broke. Every other clutch in the trans looks like new @ 100K. I have to admit I was being a little rough on it when it broke. I was curious to see just how far I could push it before it broke. Surprisingly, it seemed to brake quite easily. Needless to say, now all night I am nervous to hit the accel pedal in R and D1. The experience has slowed me down for sure.