1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2001 Silverado/Sierra Headlight Wiring, Sno-Way Plow

Discussion in 'Truck & Equipment Repair' started by Bens95cobra8594, Jan 21, 2011.

  1. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

    Hi, I just recently got a Sno-Way 7'6" plow for my 2001 Sierra 1500 RCSB. The headlight wiring harness the came with it is a little suspect... i.e. seems to be missing some connections.
    I installed it the other day to the best of my ability and just the truck lights worked (the right side, dimly-so).
    I simply unplugged the stock high and DRLs and installed the harness in line and grounded it (I didn't fool with the turn signals as of yet). And after this was installed, only the truck lights worked.
    So what I am wondering:
    1) Should the plow be raised in order for the lights to work (doubt it, as there is no wiring going to the plow mechanism/brain)?
    2) Should there be an in-and-out plug on both sides? Meaning, in the first photo below, there are clearly in and out plugs but on the other side, there is only an in plug. Very odd...

    [​IMG]

    [​IMG]

    [​IMG]

    Any help is appreciated.

    If for some reason this won't plug-and-play, I will probably just hack apart the harness to install the Meyers Night Sabre (I) system that I have for another (disabled) plow truck. I just like the functionality of plug-and-play, but have no problem actually wiring things in .

    Thanks!
     
  2. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

    bump... anyone?
     
  3. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Did you hook up the parkig lights? The plow uses them as a trigger, and you have to hook up both lights. It does look like it could be the right harness adpter. Are there two relays?
     
  4. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

    Yes, hooked up the lights:
    1) grounded white wire to core support (to bare metal).
    2) hooked up in and out on left side (did not connect turn signal/running light wires).
    3) hooked up in and out on right side (did not connect turn signal/running light wires).

    There is only one relay (pictured below).

    In the first photo:
    I question what the yellow and brown wires are for. Yellow I assume is turn signal.
    I question why there are two large three-prong plugs on the left side of the harness, but not the right. These include the in and out parts of the plug-and-play harness.

    In the third photo:
    There is a single black wire, cut apart, not sure where that goes.
    There is an extra plug for the lights, but not sure what that went to (on the Sno-Way harness)
    I assume the yellow is for the turn signal again.

    Thanks for your help!
     
  5. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    Nothing will happen until you attach the parking lights (brown wire). You feed the passenger side though the plow harness. Make sure the white wire between the two headlights is connected. the cut wire is parking lights.
     
  6. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

    Ok, gotcha. So what are the color wires for?
    Yellow = ?
    Brown = Parking Lights
    Black = ?
     
  7. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

  8. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

  9. basher

    basher PlowSite Fanatic
    from 19707
    Messages: 8,992

    So you need a 99100411 adapter.
     
  10. Bens95cobra8594

    Bens95cobra8594 Junior Member
    Messages: 29

    Basher, thank you again for the information.

    Ok, I did a little more searching and it looks like I actually have this harness:

    http://www.snoway.com/service/LightKits/97100352c.pdf

    Based on the adapters I already have, it seems that 1) I need a different adapter kit or 2) how would I go about plugging it in, if this is indeed the correct one?

    It just seems like something is "missing" on the right side of the harness for the feed in and out from wiring to headlights.

    Thanks!