1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2001 8.1 churping noise?

Discussion in 'Chevy Trucks' started by Mick76, Nov 17, 2011.

  1. Mick76

    Mick76 2000 Club Member
    from Maine
    Messages: 2,157

    I ve got a 2001 witht he 8.1 and allison combo.... under moderate accl I hear a churping noise (seems to be a bit louder when its cold or not up to temp yet)... I shift the tranny in neutral and rev the engine and the churping is not there...... any ideas as this is becoming annoying?!.......:help:
     
  2. White Gardens

    White Gardens 2000 Club Member
    Messages: 2,665

    Sounds like a belt. Might want to check your idler(s) to see if any of the bearings are going out.

    I say plural, because my 8.1 has two idlers for accessory setups.

    Only other thought that comes to mind is the flex-plate might be starting to crack and your hearing the metal work against each other.

    As for the tranny, I have no experience with the Allison. I have the 4l80e.

    ...
     
  3. Mick76

    Mick76 2000 Club Member
    from Maine
    Messages: 2,157

    Thanks White, I thought belt also until going down a road I decided to shift the truck in neurtal and rev the engine... no churping sound..... now put it back into drive and moderately push the accl pedal and you'd hear it...

    flex plate, man I hope not.. i had one replaced on my 6.0 to a tune of $1000.......
    Thanks for your imput.....
     
  4. White Gardens

    White Gardens 2000 Club Member
    Messages: 2,665

    Could be something else but that is my first inclination. Might need to take it to a shop and have them figure it out.

    The updated flex-plate for the 8.1 is around 250. Luckily my neighbor is a mechanic and we swapped work. Also my truck is a 2wd, Cab and Chassis, so we didn't have to hardly lift it up to pull the tranny and do the swap.
     
  5. chris694205

    chris694205 Senior Member
    Messages: 175

    my 8.1 makes a noise almost the same to what you are speaking of. When it first starts cold until it warms up a bit. I have heard that the trans oil filter inside develop a leak around the seal and suck air?? But i havent replaced that yet in order to find out
     
  6. Schnabel Plowin

    Schnabel Plowin Senior Member
    Messages: 139

    The inside filter is easy to change and costs less than $50. Just drain the oil, take out the 12-15 bolts holding the pan on and drop it. You will be able to see it from there. Just pull, swap, and reverse the process. Also, to the OP, have you hooked up a scanner to check for codes or to run a test while driving?
     
  7. Mick76

    Mick76 2000 Club Member
    from Maine
    Messages: 2,157

    Yes no codes... I've actually changed that darn filter twice..... once I did it and the thing just slipped out of its holes that it mounts into.. the second time I had my mechanic do it and it did the same thing to him
     
  8. Schnabel Plowin

    Schnabel Plowin Senior Member
    Messages: 139

    How does the filter o ring look?
     
  9. Mick76

    Mick76 2000 Club Member
    from Maine
    Messages: 2,157

    To be honest I don't know... this things been a pita....what should I look for? I mean the filter thats in there now is new and its still making that noise....
     
  10. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    I'm thinking its a belt.Check all the pulleys while your at it.I had mine start making a churping noise then a winding noise and it ended up needing a belt and tensioner.
     
  11. Mick76

    Mick76 2000 Club Member
    from Maine
    Messages: 2,157

    I dont think its a belt...... wouldnt the belt "churp" going down the road when the tranny is in neutral? It doesnt churp when the tranny is in neutral but does churp when its in drive and under alittle acceleration.....
     
  12. chevyzrule810

    chevyzrule810 PlowSite.com Addict
    Messages: 1,239

    I just red your post then if its not churping when its in neutral then its not a belt
     
  13. 496 BB

    496 BB Senior Member
    Messages: 789

    Do you have an air intake on it like a K&N?
     
  14. Mick76

    Mick76 2000 Club Member
    from Maine
    Messages: 2,157

    Nope, stock air box
     
  15. Schnabel Plowin

    Schnabel Plowin Senior Member
    Messages: 139

    Can you get a friend to rev it parked in "drive" so you can go around and pinpoint the sound location? Especially helpful if it is the tranny or the engine.
     
  16. 496 BB

    496 BB Senior Member
    Messages: 789

    Does it do it when you slowly rev it? Full throttle do it also? Is it whistle? What Im getting at is maybe your air intake is loose somewhere or the intake itself is leaking. Check engine compartment with someone barley pressing gas pedal.

    I think I know what your talking about though if its the trans. Sounds like metal scraping or something but mines done it for years when its cold. Goes away fairly quickly.