1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

2 boss plow problems!!!!

Discussion in 'Boss Plows Discussion' started by kslandscaping, Jan 25, 2012.

  1. kslandscaping

    kslandscaping Junior Member
    Messages: 1

    hi guys new to the site but sure is helpful... well hears my problem I have a 1999 3500hd 6.5lt diesel with a 9.2 vee and my problem is plow works great with truck lights on... soon as i switch over to plow lights i have no control motor runs wont shut off til i pull power wire from truck to plow...controler runs even when shuting it off... now i pulled the controler and test lighted the harness i got power to black only with truck lights on... when switching to plow i got power to black and slight power to all the pins???

    problem 2... switched plows on trucks from a 2001 f250 7.3 diesel with 8.2 vee and put it on 1997 f350 7.3 diesel with 8.6 straight blade did a flop with them when i put the 8.2 vee on 97 the lights wouldn't work when i would swith it over to plow lights it would show the high beam indicator on ever when the low beams were on... now my 2001 has the rocker switch to change truck to plow lights and my 97 has the silver toggle... still dosen't make sense why the high beam indicator won't shut off... or no high beam lights... is it cause its an 11 pin to 13 pin?!?!?!?! please help...