1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

1996 Blazer running hot with plow on

Discussion in 'Commercial Snow Removal' started by scholzee, Jan 5, 2005.

  1. scholzee

    scholzee Senior Member
    Messages: 242

    My 1996 S10 2 dr blazer with a western 6 1/2 foot blade is running hot. My temp gauge has not work right for awhile, The gage starts at 100F and center is 210F. when the truck is running the max I see on the gauge is 140 F. The heat blows nice and warm and melts ice off the windshield. The gauge sending unit is hard to get at, I bought a new one and connected it up to the harness and put it in a pot of boiling water and the dash gauge still read 140 F. So maybe the dash gauge or wiring is flaky. With the plow on going 55 on the highway the gauge gets up to about 210. I tried lowering the blade and angle, left ,right and cannot get the temp down. Around town it does not get too hot and plowing it stays lower. The pump blocks most of my grill on the truck, does the blade create some kind of vacuum in front of the blade that prevents air from flowing through the radiator ? The truck has a stock clutch fan in good shape I would think with the temp rising it could activate and pull air in. Any thoughts or ideas are appreciated.
  2. IndySnowPlow

    IndySnowPlow Senior Member
    from Indiana
    Messages: 214

    Sounds as though when you increase your vehicle speed and keep it constant ( hiway ) then yes, the blade is moving the air out & around the radiator causing the engine temp to increase. You could try installing an electric fan for cooling.
  3. mreamer

    mreamer Member
    Messages: 85

    The first thing I would do is get the temp gauge working correctly. If you can't trust the reading, you can't be sure if you have a problem or not. Just my .02