1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

1990 chevy silverado 1500 heater & a/c controls not working?

Discussion in 'Chevy Trucks' started by hunter123420, May 19, 2009.

  1. hunter123420

    hunter123420 Junior Member
    Messages: 1

    No power to A/C & heater control head??? was working fine this morning when i went to work, when i came out to start my truck it wouldn't, notice I had a loose battery terminal. when i got in my truck noticed no power the those controls I checked fused it was fine anybody have any ideas what is wrong????
  2. swannkm

    swannkm Junior Member
    Messages: 1

    Heater control issue

    Did you ever figure out what the problem was? I'm having the same issue today. Let me know.

  3. t.i.b

    t.i.b Senior Member
    Messages: 140

    i had that happen in a 92 and it was the harness beind the dash had come loose. hope that helps.
  4. richland

    richland Junior Member
    from montana
    Messages: 1

    1990 chevy

    When you say the harness plug was unhooked behind the dash, do you mean the actual plug to the heater control or further down the harness?
  5. gmcdan

    gmcdan Senior Member
    Messages: 107

    I was having some instrument panel light problems that i couldnt figure out , the fuse was good but for some reason it still didnt work . changed fuse and it worked , i think it had some sort of build up on the terminals that blocked the current but it wasnt blown.