1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

1984 k10 4x4

Discussion in 'Chevy Trucks' started by lvfd50, Dec 10, 2009.

  1. lvfd50

    lvfd50 Junior Member
    from WNY
    Messages: 14

    So figures on the first decent snow of this season I end up having trouble with my 4X4. I was wondering if anyone could give me a direction to look for the problem.
    -The hubs turn and one moves to the locked position, but the other makes it almost all the way. Only about the width of the arrow on the part that turns away from locked. It may actually be locked but not sure.
    -It seems like the transfer case is shifting because when I try to put it in 4Lo and then shift the truck to drive, back to N and then reverse I hear it click or grind a little like it has always done in 4Lo. This goes away in 4Hi and 2 wheel.
    -Not sure if something is froze, but we did have a crazy mix of rain/sleet and later snow overnight.

    Where do you guys think I should start looking? or what are some tests I should do to narrow it down. The only problem I had last year was the splines in the slip joint of the front drive shaft went bad, but I replaced the shaft with another one I had and everything was fine after that. Thanks in advance for any help.
  2. yardsmith

    yardsmith Senior Member
    Messages: 248

    I would get it inside & take the caps off the locking hubs & clean/grease them, & PB Blaster all the linkage for the transfer case underneath the truck. While you're under there, look for anything in the way or binding up on all the linkages. Start there & see if it improves.