1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

11 HP Honda specs

Discussion in 'Commercial Snow Removal' started by 64duck, Nov 14, 2014.

  1. 64duck

    64duck Junior Member
    Messages: 6

    Does anyone have a honda engine used on the western Ice Breaker salt spreaders they could look at and give me the specs. I do not see any reason to give western $2500.00 for this engine. Thank you.
     
  2. ProperLandscape

    ProperLandscape Member
    Messages: 91

    Honda 11.0 OHV GXV340

    http://www.brandnewengines.com/GXV340-DET3-2.aspx

    This was the engine on my spreader, pretty sure it wasn't original but it worked. $895. The honda engine was an option. The briggs are easier to find and cheaper but i would much rather have a honda.
     
  3. concreteguy

    concreteguy Senior Member
    Messages: 130

    Call Russo's Power Equipment. They have the replacement engines for spreaders. The engine for my Swenson, which is a 13 hp Honda, is $805. Not that I need one, I was there today and happened to inquire, just in case. They have one in Naperville and Schiller Park
     
  4. They have one in Frankfort also opens on the 19th
     
  5. john r

    john r Senior Member
    from NJ
    Messages: 239

    If I had a choice I would without a doubt get a HONDA! I hate to say it but we have had nothing but problems with the Briggs engines. Even while under warrantee no one could fix the cold start problems. What a shame.. All our snow blowers are Honda powered. Never let us down yet!
     
  6. concreteguy

    concreteguy Senior Member
    Messages: 130

    Correct, I forgot to mention
     
  7. concreteguy

    concreteguy Senior Member
    Messages: 130

    Did you adjust the choke so as to make sure it was closing completely
     
  8. john r

    john r Senior Member
    from NJ
    Messages: 239

    Yes I checked the electric choke and works fine. I did the fix my self. The carbs seem to be the problem. Bought 2 new ones. It starts better when cold but it's still not right the way it should be. I think the EPA carbs are the problem. But this should not be my problem. Briggs unloaded what they have and I got stuck for 2 of them.