1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

07 Tundra Extra Relay

Discussion in 'Blizzard Plows Discussion' started by chrisps, Dec 8, 2010.

  1. chrisps

    chrisps Junior Member
    Messages: 13

    Hello,

    I have a Blizzard 760LT Plow that I picked up off craigslist for my 07 Toyota Tundra. I noticed that the plow has on the lighting harness an extra relay from what is in the manual. First question is do I need the extra relay? I think I may since when my high beams are on the low beams are also on. At least that's what I've gathered from googling. If I do need the extra relay does anyone know where or have a schematic on how to wire it up. It is already wired up but I want to make sure it is done correctly. Any help is appreceated.

    Thanks,



    Chris
     
  2. chrisps

    chrisps Junior Member
    Messages: 13

    Update

    Still haven't found a schematic or digram but I did find a post that pertains to what I'm talking about hopefully it will helpd describe the situation better.

    Sharpcut 112-26-2009, 12:20 AM
    Truck end wiring for a 720 and 760 are identical. If you pay attention, your 2008 chevy will light up the high and low beams when you put on the high beams on the truck. Since Blizzard uses only one bulb for high and low beam, they dont want power going to both the high and low beams at the same time. For this purpose, your installer should of added a 3rd relay to each side of your headlight wiring harness. if you follow the back of your headlight wiring, you should end up finding 3 relays per side(for a total of 6) that control your plow headlights. They will havean assortment of Green, Yellow, an black wires going to them.The third relay is needed for 2007 and up Chevys to shut off the low beam when high beams are on.

    I have an 07 Tundra and I did confirm last night that when high beams are on low beams stay on so it looks like I need the 3rd. relay. I still don't know how it is supposed to be wired in.

    Thanks,



    Chris
     
  3. atrinh15

    atrinh15 Junior Member
    Messages: 28

    So did you get the right wire harness for your truck? The main harness I believe is all the same on the 760LT. On the light adapter is where it would change from vehicle to vehicle including the undercarriage mount. All these plows are plug and play unless your modify the harness.
     
  4. chrisps

    chrisps Junior Member
    Messages: 13

    Got it working don't know if I need the extra relay

    So I got it working (kind of) Plow lights switch from plow to truck no problem. Only issue is when I have the plow lights on I have to have the high beams on. No plow lights if the low beams are on. When switch is on truck side then high and low beams work as they should. I Still don't know if I need the extra relay on each side or not, the guy I bought the plow off had it on an 08 Tundra so he says so I kept the extra relay in. Still would like confirmation as to weather or not I should be using a total of 6 relays on the lighting harness or only 4 for my truck.

    Thanks,



    Chris
     
  5. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    Guys,
    Go onto the Blizzard website, search under the Service section, there is an all literature section which has electrial and mounts in it. You are looking for the install instructions for the Relay kit 29453. It will show you how to wire in the extra relay. If I knew how to link it to this post, I would. I'm a lot better with snow plows than computers!!;)
     
  6. chrisps

    chrisps Junior Member
    Messages: 13

    Sharpcut 1

    Ok I went onto the blizzardplows.com site and I selected Parts & Service. On that page I was given two choices "Service Publications Library" an Power Search I did the power search first and tried searching for 29453 didn't find anything I also tried Relay Kit 29453 and still didn't find anything. So I went back and tried "Service Publication Library" I looked under "Undercarriage Kit - Parts List & Installation Insructions" then Toyota Undercarrigae Kits I found the B35333 Kit for Model 760LT which is the one that I have on my truck but no mention of a 29453 in that document. I also looked under "Undercarriage & Light Adapter Reference Guides" no 29453 mentioned in there. Then also under "Electrical & Hydraulic - Parts List & Installation Instructions" and "Miscellaneous". I also tried searching google for 29453, Relay 29453, Blizzard 29453, ect. no luck.

    Thanks,



    Chris
     
  7. Sharpcut 1

    Sharpcut 1 Senior Member
    Messages: 386

    If you have access to a fax, send me the #' and I'll fax you over the instructions. Only 2 pages.
     
  8. chrisps

    chrisps Junior Member
    Messages: 13

    I don't have a fax but I could probably get access to one. I don't know how I'll be able to get you the fax number I don't really want to post it on here and it doesn't look like I have PM on here. I see that your online so if you get this let me know and I can set up a quick gmail account to use to have you send me your email address and then I can send you the fax number.

    Thanks,




    Chris
     
  9. chrisps

    chrisps Junior Member
    Messages: 13

    ok you can e-mail me your e-mail at plowsite@gmail.com and then I'll send you the fax number. The fax is shared with a phone line so I would have to know when you would be sending it so the phone doesn't get picked up. Thanks again for all your help.
     
  10. chrisps

    chrisps Junior Member
    Messages: 13

    Blizzard Relay Kit Installation Instructions 29453

    Thank you Sharpcut 1 for the following information on the extra relay needed for vehicals that low beams stay on when you turn on high beams.

    If anyone has a digital copy or a better copy than the one that I have posted please post. This copy was faxed and then scanned and posted so quality has suffered a bit.

    Thanks,



    Chris
     

    Attached Files: