1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

07.5, 6.7l check gauge light

Discussion in 'Ram Trucks' started by cmo18, Jan 23, 2014.

  1. cmo18

    cmo18 Senior Member
    Messages: 815

    Over the past month randomly the check gauge light would come on and then go off. I replaced both batteries.

    For the past week the light comes on and stays on, throws cel code p063c, plowed last night for 10 hours with no obvious electrical problems. Then at the end of the night on the over head display it chimed and said service required see dealer but no additional codes. The truck does squeal a little when wet out,

    Could it be alt going bad? Just connections?? Any help I'm stumped.
     
  2. 1olddogtwo

    1olddogtwo PlowSite Fanatic
    Messages: 11,538

    does it squeal like a pig?

    what kind of scanner are you using

    first thing I would do is check all the grounds.... I mean ALL the grounds
     
  3. cl733

    cl733 Senior Member
    from Canada
    Messages: 252

  4. cmo18

    cmo18 Senior Member
    Messages: 815

    No not like a pig, just a light one..then it got real cold again and squeak is gone.

    When the truck had warranty and a real bad squeak the dealership said it had dirty pullies causing the belt to slip. I wonder if the belt is slipping causing check gauge light?
     
  5. cmo18

    cmo18 Senior Member
    Messages: 815