1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

07 1500 running hot

Discussion in 'Chevy Trucks' started by ppandr, Jan 28, 2011.

  1. ppandr

    ppandr Senior Member
    Messages: 619

    My partner has a 07 1500 auto trans and says it has been running hotter than normal while plowing. Without the plow on or just at idle is runs normal. We have had the plow on for 3 years now, seems to be getting worse the last few weeks according to him. I have not had the time to look at it yet but anyone else have the same issues. I have researched it a little and seems like it's a common problem to these trucks, like the front wheel hubs are as well.
    Seems everyone has a different fix....T-stat, flush coolant, fan clutch (but it has electric fans?)
    Any ideas......?
     
  2. jklawn&Plow

    jklawn&Plow Senior Member
    Messages: 469

    I would record the temps at specific durations of plwwing with the plow all the way up. Then try to keep the plow lower and record again. See where you are temp wise. These systems are under high pressure so the boiling point is pretty high-not sure where the red line is? See if you really have a problem or not.
     
  3. ppandr

    ppandr Senior Member
    Messages: 619

    Problem is occuring during plowing not during transport.
     
  4. BIGGB9

    BIGGB9 Senior Member
    Messages: 148

    I would change the trans fluid and use full synthetic it makes a big difference.