1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

06 f350 no cruise, no horn

Discussion in 'Ford Trucks' started by AndersonCS, Nov 24, 2011.

  1. AndersonCS

    AndersonCS Member
    Messages: 90

    So my 1 ton suddenly developed the problem above. I'm guessing its in the harness in the column as I can hear some dragging when you turn lock to lock. I guess we'll see what happens Friday when Scaffidi's look at it.

    Anyone ever have this, its got 179XXX miles. Been a good truck so far except the rear end I had to change out, my abuse brought that on. My family used to own 3 6.0's now where down to 2. Had to get a 6.7 scorpion to try. :gunsfiring:
     
  2. AndersonCS

    AndersonCS Member
    Messages: 90

    I suppose I should add that I checked every fuse on the truck. It could be some relay but idk
     
  3. mcfly89

    mcfly89 Senior Member
    Messages: 306

    clock spring in steering column
     
  4. AndersonCS

    AndersonCS Member
    Messages: 90

    Lol never thought about that.
     
  5. mcfly89

    mcfly89 Senior Member
    Messages: 306

    I didnt have any trouble replacing the one in my 99 f250, but they CAN be a pain
     
  6. AndersonCS

    AndersonCS Member
    Messages: 90

    Dealer called before lunch, clock spring is the problem. Makes sense because last winter the airbag light flashed a few times and then this spring the cruise was acting up/not working every once in a great while.