1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

06' 6.0 troubles

Discussion in 'Ford Trucks' started by jkiser96, Sep 11, 2011.

  1. jkiser96

    jkiser96 Senior Member
    Messages: 401

    I have an 06' F-350 with the dreaded 6.0 that decided to die yesterday. It has been sitting for a couple weeks & when I started it yesterday, it ran for a few minutes & then started running rough & black smoking real bad. After a couple of minutes of this it died & will not fire now. When I try starting it, it belches black smoke but will not fire. Anyone have any ideas of what this may be? Thanks
  2. JD822

    JD822 Member
    Messages: 55

  3. coldcoffee

    coldcoffee Senior Member
    Messages: 776

    I just had my IDM rebuilt this past June. That's after installing an entire new engine harness and FICM last January. Codes should be pulled & if your careful, there are tests you can do yourself as stated above.

    Not to jump the gun here, but you can save yourself a lot of money having them rebuilt. This guy on Ebay did mine, but I sent him my unit Fedex w/ a paid return slip...he did the repair the same day he got it & sent it back the same day...also gives a 1 year warranty. When it was in the shop back in January, my mechanic had a used one mailed from Alabama & sent USPS...big mistake, unit was stopped by homeland sec. , because it was an electronic devise. I wouldn't think twice about using this guy again. He also explains how to test in his ad: