1. Welcome to PlowSite. Notice a fresh look and new features? It’s now easier to share photos and videos, find popular topics fast, and enjoy expanded user profiles. If you have any questions, click HELP at the top or bottom of any page, or send an email to help@plowsite.com. We welcome your feedback.

    Dismiss Notice

'05 dodge ram 2500/Blizzard Install Question

Discussion in 'Ram Trucks' started by ed salvatore, Nov 21, 2005.

  1. ed salvatore

    ed salvatore Member
    from boston
    Messages: 71

    Last week had a dealer install a new 800 onto my above truck. After picking up the truck I looked it over. I noticed that the driver's side upper attachment brace (runs upward along frame rail and bolts to inside of frame rail with one large bolt), had no washer on the bolt, and noticed that the 5 inch "shoulder", or "shelf" of it that runs underneath the bottom of the frame rail really was not in contact with the frame rail. I can partially slide my hand in between the "shoulder" and the bottom of the frame rail a bit, because they don't appear to touch. :confused: The other side, passenger, sits up nice and tight just under the frame rail, and that bolt has a washer. I tried to loosen the bolt, but couldn't get it to move. Thought I might add a washer and attempt to reposition it, if possible, up against the bottom of the frame rail. Part number sticker appears to match that which is called for for this application, but the fit on this side is lousy.

    Have other Dodge owners or Blizzard installers noticed this on their truck???Is this common to the Dodge with Blizzards? Should I be concerned with this?

    Dealer is a bit of a drive, so I'm thinking of bringing it into a local shop and asking them to see if they can correct this.

    Appreciate any help. Thanks a lot.